aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorTobias Schramm <tobleminer@gmail.com>2018-09-04 02:08:01 +0200
committerMathias Kresin <dev@kresin.me>2018-10-07 10:46:20 +0200
commitfa3c2676ab0ce5fbb648249da31e31bbc61a3e3d (patch)
treedde6645095330382aa62a655f2519698bcaa45f3 /target/linux/ath79/image/generic-ubnt.mk
parent5736af8024bed7a49a8a3e469436bdfe0c02c312 (diff)
downloadupstream-fa3c2676ab0ce5fbb648249da31e31bbc61a3e3d.tar.gz
upstream-fa3c2676ab0ce5fbb648249da31e31bbc61a3e3d.tar.bz2
upstream-fa3c2676ab0ce5fbb648249da31e31bbc61a3e3d.zip
ath79: Add support for Ubiquiti Nanostation AC
5 GHz AC wireless outdoor PoE CPE with internal 2.4 GHz management radio CPU: Atheros AR9342 SoC RAM: 64 MB DDR2 Flash: 16 MB NOR SPI Switch: QCA8334 Ports: 2 GbE ports (1x PoE in, 1x PoE passthrough) WLAN: 5 GHz QCA899X (PCI) and 2.4 GHZ AR9342 Successor to the old NanoStation M5 with AC wireless. The integrated QCA899X is a Ubiquiti branded part with modified vendor and product id (0777:11ac9). Serial Serial settings: 115200, 8N1 * = plated through hole 0 = nylon screw [Top of device] +--------------------------+ | [label] | | 0 | | 0 | | [ubnt] | | [logo] 3V3 * | | TX * | | RX * | | GND * | | | | * | | * | | * | | * | | 0 | | 0 | | | | | Installation 1. Connect to serial header on device 2. Power on device and enter uboot console 3. Set up tftp server serving an openwrt initramfs build 4. Load initramfs build using the command tftpboot in the uboot cli 5. Boot the loaded image using the command bootm 6. Copy squashfs openwrt sysupgrade build to the booted device 7. Use mtd to write sysupgrade to partition "firmware" 8. Reboot and enjoy Signed-off-by: Tobias Schramm <tobleminer@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 86afa11deb..91cd5fc681 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -84,6 +84,16 @@ define Device/ubnt_nano-m
endef
TARGET_DEVICES += ubnt_nano-m
+define Device/ubnt_nanostation-ac
+ $(Device/ubnt-wa)
+ DEVICE_TITLE := Ubiquiti Nanostation AC
+ DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ IMAGE_SIZE := 15744k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_nanostation-ac
+
define Device/ubnt_nanostation-ac-loco
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti Nanostation AC loco