aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2018-07-02 14:39:54 +0200
committerMathias Kresin <dev@kresin.me>2018-07-07 21:07:40 +0200
commite420b7b5c517d03e1282b5889065e22143f9c4ef (patch)
tree58338d26fb98253f91e8309bae8524d720e36f0e /target/linux/ath79/image/generic-ubnt.mk
parent16d6a63f857a4e9eeb1f173e964264d8a06e65eb (diff)
downloadupstream-e420b7b5c517d03e1282b5889065e22143f9c4ef.tar.gz
upstream-e420b7b5c517d03e1282b5889065e22143f9c4ef.tar.bz2
upstream-e420b7b5c517d03e1282b5889065e22143f9c4ef.zip
ath79: add support for UniFi AC-Mesh Pro
The Unifi AC-Mesh Pro has identical hardware to the Unifi AC-Pro except USB support. Furthermore for setting parameters like antenna gain it is helpful to know the exact device variant. Signed-off-by: Christoph Krapp <achterin@googlemail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 540277d41b..4681996a7b 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -103,6 +103,13 @@ define Device/ubnt_unifiac-mesh
endef
TARGET_DEVICES += ubnt_unifiac-mesh
+define Device/ubnt_unifiac-mesh-pro
+ $(Device/ubnt_unifiac)
+ DEVICE_TITLE := Ubiquiti UniFi AC-Mesh Pro
+ SUPPORTED_DEVICES += ubnt-unifiac-mesh-pro
+endef
+TARGET_DEVICES += ubnt_unifiac-mesh-pro
+
define Device/ubnt_unifiac-pro
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Pro