aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-17 08:01:55 +0100
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:38 +0100
commitdb4b6535f837a1e335a560f8aeb2cf61973865b7 (patch)
tree5f3f4f4ac0c8eb59b0a4c54967caae0d8edd9fe2 /target/linux/ath79/image/generic-ubnt.mk
parentae2b43b873fb5e2326509af2807f75fde27e92b0 (diff)
downloadupstream-db4b6535f837a1e335a560f8aeb2cf61973865b7.tar.gz
upstream-db4b6535f837a1e335a560f8aeb2cf61973865b7.tar.bz2
upstream-db4b6535f837a1e335a560f8aeb2cf61973865b7.zip
ath79: Add support for Ubiquity Bullet M (XW)
CPU: AR9342 SoC RAM: 64 MB DDR2 Flash: 8 MB NOR SPI Ports: 100 MBit (24V PoE in) WLAN: 2.4/5 GHz UART: 1 UART on PCB marked as J1 with 115200 8N1 config LEDs: Power, Ethernet, 4x RSSI LEDs (orange, red, 2x green) Buttons: Reset UART connection details .---------------------------------. | | [ETH] J1 [ANT] | o VCC o RX o TX o GND | `---------------------------------' Flashing instructions A) Serial console, U-Boot and TFTP 1. Connect to serial header J1 on the PCB 2. Power on device and enter U-Boot console 3. Set up TFTP server serving an OpenWrt initramfs build 4. Load initramfs build using the command tftpboot in the U-Boot cli 5. Boot the loaded image using the command bootm 6. Copy squashfs OpenWrt sysupgrade build to the booted device 7. Use mtd to write sysupgrade to partition "firmware" 8. Reboot and enjoy B) Experimental factory image flashing over SSH from airOS v6.1.7 1. You need to flash your UBNT M2HP with airOS v6.1.7 firmware no other airOS version is currently supported 2. git clone https://github.com/true-systems/ubnt-bullet-m2hp-openwrt-flashing 3. cd ubnt-bullet-m2hp-openwrt-flashing 4. make flash-factory FW_OWRT=/path/to/your/openwrt-ath79-generic-ubnt_bullet-m-xw-squashfs-factory.bin Tested only on Bullet M2HP. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index bb86c8b288..2d0b1adadb 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -63,6 +63,15 @@ define Device/ubnt-wa
ATH_SOC := ar9342
endef
+define Device/ubnt-xw
+ $(Device/ubnt)
+ UBNT_TYPE := XW
+ UBNT_CHIP := ar934x
+ UBNT_BOARD := XM
+ UBNT_VERSION := 6.0.4
+ ATH_SOC := ar9342
+endef
+
define Device/ubnt_bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M
@@ -70,6 +79,13 @@ define Device/ubnt_bullet-m
endef
TARGET_DEVICES += ubnt_bullet-m
+define Device/ubnt_bullet-m-xw
+ $(Device/ubnt-xw)
+ DEVICE_TITLE := Ubiquiti Bullet-M (XW)
+ SUPPORTED_DEVICES += bullet-m-xw
+endef
+TARGET_DEVICES += ubnt_bullet-m-xw
+
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Rocket-M