aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-08-22 14:34:45 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-21 22:17:39 +0200
commitd1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e (patch)
treea2614da6820e57eb436289d821f7f9a06fa0ee86 /target/linux/ath79/image/generic-ubnt.mk
parent4fc0a61ed3da96330d30703a2a039a6a06dc0b2f (diff)
downloadupstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.tar.gz
upstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.tar.bz2
upstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.zip
ath79: sort device definitions in image/*
This applies alphabetic sorting to devices in image/* files. For certain cases, this patch deviates from strict sorting, e.g. to ensure that v10 comes after v9. While at it, fix an indent and remove some useless empty lines. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk150
1 files changed, 75 insertions, 75 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 0548f0a587..4b2cee215c 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -44,16 +44,6 @@ define Device/ubnt
append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | mkubntimage-split
endef
-define Device/ubnt-xm
- $(Device/ubnt)
- DEVICE_VARIANT := XM
- DEVICE_PACKAGES += kmod-usb-ohci rssileds
- UBNT_TYPE := XM
- UBNT_CHIP := ar7240
- ATH_SOC := ar7241
- KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
-endef
-
define Device/ubnt-bz
$(Device/ubnt)
UBNT_TYPE := BZ
@@ -70,6 +60,16 @@ define Device/ubnt-wa
ATH_SOC := ar9342
endef
+define Device/ubnt-xm
+ $(Device/ubnt)
+ DEVICE_VARIANT := XM
+ DEVICE_PACKAGES += kmod-usb-ohci rssileds
+ UBNT_TYPE := XM
+ UBNT_CHIP := ar7240
+ ATH_SOC := ar7241
+ KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
+endef
+
define Device/ubnt-xw
$(Device/ubnt)
DEVICE_VARIANT := XW
@@ -81,6 +81,18 @@ define Device/ubnt-xw
ATH_SOC := ar9342
endef
+define Device/ubnt_acb-isp
+ $(Device/ubnt)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 15744k
+ DEVICE_MODEL := airCube ISP
+ UBNT_BOARD := ACB-ISP
+ UBNT_TYPE := ACB
+ UBNT_CHIP := qca9533
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += ubnt_acb-isp
+
define Device/ubnt_airrouter
$(Device/ubnt-xm)
DEVICE_MODEL := AirRouter
@@ -102,27 +114,6 @@ define Device/ubnt_bullet-m-xw
endef
TARGET_DEVICES += ubnt_bullet-m-xw
-define Device/ubnt_rocket-m
- $(Device/ubnt-xm)
- DEVICE_MODEL := Rocket-M
- SUPPORTED_DEVICES += rocket-m
-endef
-TARGET_DEVICES += ubnt_rocket-m
-
-define Device/ubnt_nanostation-m
- $(Device/ubnt-xm)
- DEVICE_MODEL := Nanostation M
- SUPPORTED_DEVICES += nano-m
-endef
-TARGET_DEVICES += ubnt_nanostation-m
-
-define Device/ubnt_nanostation-m-xw
- $(Device/ubnt-xw)
- DEVICE_MODEL := Nanostation M
- SUPPORTED_DEVICES += nanostation-m-xw
-endef
-TARGET_DEVICES += ubnt_nanostation-m-xw
-
define Device/ubnt_lap-120
$(Device/ubnt-wa)
DEVICE_MODEL := LiteAP ac
@@ -160,6 +151,59 @@ define Device/ubnt_nanostation-ac-loco
endef
TARGET_DEVICES += ubnt_nanostation-ac-loco
+define Device/ubnt_nanostation-m
+ $(Device/ubnt-xm)
+ DEVICE_MODEL := Nanostation M
+ SUPPORTED_DEVICES += nano-m
+endef
+TARGET_DEVICES += ubnt_nanostation-m
+
+define Device/ubnt_nanostation-m-xw
+ $(Device/ubnt-xw)
+ DEVICE_MODEL := Nanostation M
+ SUPPORTED_DEVICES += nanostation-m-xw
+endef
+TARGET_DEVICES += ubnt_nanostation-m-xw
+
+define Device/ubnt_rocket-m
+ $(Device/ubnt-xm)
+ DEVICE_MODEL := Rocket-M
+ SUPPORTED_DEVICES += rocket-m
+endef
+TARGET_DEVICES += ubnt_rocket-m
+
+define Device/ubnt_routerstation_common
+ DEVICE_PACKAGES := -kmod-ath9k -wpad-mini -uboot-envtools kmod-usb-ohci kmod-usb2 fconfig
+ DEVICE_VENDOR := Ubiquiti
+ ATH_SOC := ar7161
+ IMAGE_SIZE := 16128k
+ IMAGES := factory.bin
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
+ KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
+ KERNEL_INITRAMFS := kernel-bin | append-dtb
+endef
+
+define Device/ubnt_routerstation
+ $(Device/ubnt_routerstation_common)
+ DEVICE_MODEL := RouterStation
+ UBNT_BOARD := RS
+ UBNT_TYPE := RSx
+ UBNT_CHIP := ar7100
+ DEVICE_PACKAGES += -swconfig
+ SUPPORTED_DEVICES += routerstation
+endef
+TARGET_DEVICES += ubnt_routerstation
+
+define Device/ubnt_routerstation-pro
+ $(Device/ubnt_routerstation_common)
+ DEVICE_MODEL := RouterStation Pro
+ UBNT_BOARD := RSPRO
+ UBNT_TYPE := RSPRO
+ UBNT_CHIP := ar7100pro
+ SUPPORTED_DEVICES += routerstation-pro
+endef
+TARGET_DEVICES += ubnt_routerstation-pro
+
define Device/ubnt_unifi
$(Device/ubnt-bz)
DEVICE_MODEL := UniFi
@@ -202,47 +246,3 @@ define Device/ubnt_unifiac-pro
SUPPORTED_DEVICES += ubnt-unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-pro
-
-define Device/ubnt_routerstation_common
- DEVICE_PACKAGES := -kmod-ath9k -wpad-mini -uboot-envtools kmod-usb-ohci kmod-usb2 fconfig
- DEVICE_VENDOR := Ubiquiti
- ATH_SOC := ar7161
- IMAGE_SIZE := 16128k
- IMAGES := factory.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
- KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
- KERNEL_INITRAMFS := kernel-bin | append-dtb
-endef
-
-define Device/ubnt_routerstation
- $(Device/ubnt_routerstation_common)
- DEVICE_MODEL := RouterStation
- UBNT_BOARD := RS
- UBNT_TYPE := RSx
- UBNT_CHIP := ar7100
- DEVICE_PACKAGES += -swconfig
- SUPPORTED_DEVICES += routerstation
-endef
-TARGET_DEVICES += ubnt_routerstation
-
-define Device/ubnt_routerstation-pro
- $(Device/ubnt_routerstation_common)
- DEVICE_MODEL := RouterStation Pro
- UBNT_BOARD := RSPRO
- UBNT_TYPE := RSPRO
- UBNT_CHIP := ar7100pro
- SUPPORTED_DEVICES += routerstation-pro
-endef
-TARGET_DEVICES += ubnt_routerstation-pro
-
-define Device/ubnt_acb-isp
- $(Device/ubnt)
- ATH_SOC := qca9533
- IMAGE_SIZE := 15744k
- DEVICE_MODEL := airCube ISP
- UBNT_BOARD := ACB-ISP
- UBNT_TYPE := ACB
- UBNT_CHIP := qca9533
- IMAGES := sysupgrade.bin
-endef
-TARGET_DEVICES += ubnt_acb-isp