aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-10-07 15:33:35 +0200
committerMathias Kresin <dev@kresin.me>2018-10-07 15:44:19 +0200
commitb09992a7d912005050db22e6034f6342534753b0 (patch)
tree6581900cb347b4fa80243deb6bea11b8bda74ff4 /target/linux/ath79/image/generic-ubnt.mk
parentaf78e90d4cdb3c944d9c4f3d4d4648dd67886c4d (diff)
downloadupstream-b09992a7d912005050db22e6034f6342534753b0.tar.gz
upstream-b09992a7d912005050db22e6034f6342534753b0.tar.bz2
upstream-b09992a7d912005050db22e6034f6342534753b0.zip
ath79: fix build warning
The image build code for the Ubiquiti Nanostation AC series adds the factory image as to be build image. The same is already done by an included recipe which results into an expanded IMAGE variable of: IMAGES = sysupgrade.bin factory.bin factory.bin The build system doesn't like these duplicates and issues the following warning: Makefile:82: warning: overriding recipe for target... Get remove the duplicate factory image to get rid of the warning. Fixes: 5736af8024be ("ath79: Add support for Ubiquiti NanoStation AC loco") fa3c2676ab0c ("ath79: Add support for Ubiquiti Nanostation AC") Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk2
1 files changed, 0 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 91cd5fc681..8cdd5a2d2f 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -89,7 +89,6 @@ define Device/ubnt_nanostation-ac
DEVICE_TITLE := Ubiquiti Nanostation AC
DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
IMAGE_SIZE := 15744k
- IMAGES += factory.bin
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_nanostation-ac
@@ -99,7 +98,6 @@ define Device/ubnt_nanostation-ac-loco
DEVICE_TITLE := Ubiquiti Nanostation AC loco
DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
IMAGE_SIZE := 15744k
- IMAGES += factory.bin
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_nanostation-ac-loco