aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2020-04-24 02:22:44 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-05-17 21:03:30 +0200
commita0ef42e77c367312df7edc78dbd0d18a3faf9808 (patch)
treed4959e3bf708713517eca3289e39f5bc744d6fe2 /target/linux/ath79/image/generic-ubnt.mk
parent0486641849f4ecb6a29d0f5a9ec2b900380ba2b7 (diff)
downloadupstream-a0ef42e77c367312df7edc78dbd0d18a3faf9808.tar.gz
upstream-a0ef42e77c367312df7edc78dbd0d18a3faf9808.tar.bz2
upstream-a0ef42e77c367312df7edc78dbd0d18a3faf9808.zip
ath79: add support for Ubiquiti PowerBeam 5AC 500
The Ubiquiti PowerBeam 5AC 500 (PBE-5AC-500) is an outdoor 802.11ac 5 GHz bridge with a radio feed and a dish antenna. Specifications: - SoC: Qualcomm Atheros QCA9558 - RAM: 128 MB DDR2 - Flash: 16 MB SPI NOR (mx25l12805d) - Ethernet: 1x 10/100/1000 Mbps Atheros 8031, 24 Vdc PoE-in - WiFi 5 GHz: QCA988x HW2.0 Ubiquiti target 0x4100016c chip_id 0x043222ff - Buttons: 1x (reset) - LEDs: 1x power, 1x Ethernet, 4x RSSI, all blue - UART: not tested Not supported: - RSSI LEDs (probably through 74HC595 chip) Installation from stock airOS firmware: - Follow instructions for XC-type Ubiquiti devices on OpenWrt wiki at https://openwrt.org/toh/ubiquiti/common Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index d056ab6783..577ae98624 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -69,6 +69,15 @@ define Device/ubnt-wa
UBNT_VERSION := 8.5.0
endef
+define Device/ubnt-xc
+ $(Device/ubnt)
+ IMAGE_SIZE := 15744k
+ UBNT_BOARD := XC
+ UBNT_CHIP := qca955x
+ UBNT_TYPE := XC
+ UBNT_VERSION := 8.5.0
+endef
+
define Device/ubnt-xm
$(Device/ubnt)
DEVICE_VARIANT := XM
@@ -243,6 +252,15 @@ define Device/ubnt_picostation-m
endef
TARGET_DEVICES += ubnt_picostation-m
+define Device/ubnt_powerbeam-5ac-500
+ $(Device/ubnt-xc)
+ SOC := qca9558
+ DEVICE_MODEL := PowerBeam 5AC
+ DEVICE_VARIANT := 500
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_powerbeam-5ac-500
+
define Device/ubnt_powerbeam-5ac-gen2
$(Device/ubnt-wa)
DEVICE_MODEL := PowerBeam 5AC