aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorChristian Mauderer <oss@c-mauderer.de>2019-03-15 21:02:54 +0100
committerPetr Štetiar <ynezz@true.cz>2019-04-08 18:37:04 +0200
commit8a4dc6f48c0a4503b655195846ae1bff9a691a40 (patch)
tree6311f19ecd01cec2d644737eaaf57ffa1d9d315f /target/linux/ath79/image/generic-ubnt.mk
parentde2f888024ac58c6137959ea91f65cb6ad098df3 (diff)
downloadupstream-8a4dc6f48c0a4503b655195846ae1bff9a691a40.tar.gz
upstream-8a4dc6f48c0a4503b655195846ae1bff9a691a40.tar.bz2
upstream-8a4dc6f48c0a4503b655195846ae1bff9a691a40.zip
ath79: add support for Ubiquiti airCube ISP
The Ubiquiti Network airCube ISP is a cube shaped 2.4 GHz with internal 2x2 MIMO antennas. It can be supplied via a USB connector or via PoE. There are for 10/100 Mbps ports (1 * WAN + 3 * LAN). There is an optional PoE passthrough from the first LAN port to the WAN port. SoC: Qualcomm / Atheros QCA9533-BL3A RAM: 64 MB DDR2 Flash: 16 MB SPI NOR Ethernet: 4x 10/100 Mbps (1 WAN + 3 LAN) LEDS: 1x via a SPI controller (not yet supported) Buttons: 1x Reset Serial: 1x (only RX and TX); 115200 baud, 8N1 Missing points: - LED not yet supported - Factory upgrade via web IF or TFTP recovery not yet supported (Needs RSA signed images, for details see PR#1958) The serial port is on a four pin connextor labeled J1 and located between Ethernet and USB connector. The pinout is: 1. 3V3 (out) 2. Rx (in) 3. Tx (out) 4. GND Upgrading via serial port / U-Boot: - Connect the serial port via a level converter - Power the system and stop U-Boot with pressing any key when `Hit any key to stop autoboot` is displayed. Note: Pressing space multiple times untill U-Boot reaches that location works well. - Connect a PC with the IP 192.168.1.100 (or some other in that net) running a TFTP-Server to one of the LAN ports. Copy the sysupgrade image to the server. - Set the U-Boot server IP with setenv serverip 192.168.1.100 - Load the flash image to RAM with tftpboot 0x81000000 sysupgrade.bin - Erase the flash with erase 0x9f050000 0x9ffaffff - Write the new flash content with cp 0x81000000 0x9f050000 ${filesize} - Reset the device with reset Signed-off-by: Christian Mauderer <oss@c-mauderer.de> [removed full stop in subject and added lockdown note to commit message] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 8fddc0f1d0..b189d66770 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -229,3 +229,15 @@ define Device/ubnt_routerstation-pro
UBNT_CHIP := ar7100pro
endef
TARGET_DEVICES += ubnt_routerstation-pro
+
+define Device/ubnt_acb-isp
+ $(Device/ubnt)
+ ATH_SOC := qca9533
+ IMAGE_SIZE := 15744k
+ DEVICE_TITLE := Ubiquiti airCube ISP
+ UBNT_BOARD := ACB-ISP
+ UBNT_TYPE := ACB
+ UBNT_CHIP := qca9533
+ IMAGES := sysupgrade.bin
+endef
+TARGET_DEVICES += ubnt_acb-isp