aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2018-06-26 10:30:46 +0300
committerMathias Kresin <dev@kresin.me>2018-06-28 18:39:57 +0200
commit7dd3d7e1d3845160c2ef51e6148b452e666bd6f5 (patch)
tree2f52500febdd143f0d79ebb31ad365e3cb6d4ff6 /target/linux/ath79/image/generic-ubnt.mk
parent56fddc2577baf194d1e9a7b37d454d12ff9fb469 (diff)
downloadupstream-7dd3d7e1d3845160c2ef51e6148b452e666bd6f5.tar.gz
upstream-7dd3d7e1d3845160c2ef51e6148b452e666bd6f5.tar.bz2
upstream-7dd3d7e1d3845160c2ef51e6148b452e666bd6f5.zip
ath79: add support for Ubiquiti UniFi AC-Pro
rework the dts to a common unifi-ac dtsi pro network is connected via phy0 and has usb ports lite network is connected via phy4 without usb ports Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk18
1 files changed, 11 insertions, 7 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index aa898be2ee..31905820a0 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -81,11 +81,11 @@ endef
TARGET_DEVICES += ubnt_unifi
define Device/ubnt_unifiac
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
- DEVICE_PROFILE := UBNT
+ ATH_SOC := qca9563
IMAGE_SIZE := 7744k
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
endef
@@ -93,9 +93,13 @@ define Device/ubnt_unifiac-lite
$(Device/ubnt_unifiac)
DEVICE_TITLE := Ubiquiti UniFi AC-Lite
SUPPORTED_DEVICES += ubnt-unifiac-lite
- DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
- DEVICE_PROFILE += UBNTUNIFIACLITE
- BOARDNAME := UBNT-UF-AC-LITE
- ATH_SOC := qca9563
endef
TARGET_DEVICES += ubnt_unifiac-lite
+
+define Device/ubnt_unifiac-pro
+ $(Device/ubnt_unifiac)
+ DEVICE_TITLE := Ubiquiti UniFi AC-Pro
+ DEVICE_PACKAGES += kmod-usb-core kmod-usb2
+ SUPPORTED_DEVICES += ubnt-unifiac-pro
+endef
+TARGET_DEVICES += ubnt_unifiac-pro