aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2020-10-25 14:51:55 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-18 21:13:46 +0100
commit79f3f1358bf993a5d7ae14eba9cea2686b40841d (patch)
tree7e1a9ee0b3823789317a5b6143457db1d7030060 /target/linux/ath79/image/generic-ubnt.mk
parenta8030ea40fdba9edbba240a621c0dc3558a36e07 (diff)
downloadupstream-79f3f1358bf993a5d7ae14eba9cea2686b40841d.tar.gz
upstream-79f3f1358bf993a5d7ae14eba9cea2686b40841d.tar.bz2
upstream-79f3f1358bf993a5d7ae14eba9cea2686b40841d.zip
ath79: Add support for Ubiquiti NanoBeam AC Gen2
CPU: Atheros AR9342 rev 3 SoC RAM: 64 MB DDR2 Flash: 16 MB NOR SPI WLAN 2.4GHz: Atheros AR9342 v3 (ath9k) WLAN 5.0GHz: QCA988X Ports: 2x GbE Flashing procedure is identical to other ubnt devices. https://openwrt.org/toh/ubiquiti/common Flashing through factory firmware 1. Ensure firmware version v8.7.0 is installed. Up/downgrade to this exact version. 2. Patch fwupdate.real binary using `hexdump -Cv /bin/ubntbox | sed 's/14 40 fe 27/00 00 00 00/g' | \ hexdump -R > /tmp/fwupdate.real` 3. Make the patched fwupdate.real binary executable using `chmod +x /tmp/fwupdate.real` 4. Copy the squashfs factory image to /tmp on the device 5. Flash OpenWrt using `/tmp/fwupdate.real -m <squashfs-factory image>` 6. Wait for the device to reboot (copied from Ubiquiti NanoBeam AC and modified) To keep it consistent, we will add the gen1 variant to the nanobeam ac gen1. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index cd67ea2904..6e12c34d85 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -190,10 +190,19 @@ TARGET_DEVICES += ubnt_litebeam-ac-gen2
define Device/ubnt_nanobeam-ac
$(Device/ubnt-wa)
DEVICE_MODEL := NanoBeam AC
+ DEVICE_VARIANT := Gen1
DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct rssileds
endef
TARGET_DEVICES += ubnt_nanobeam-ac
+define Device/ubnt_nanobeam-ac-gen2
+ $(Device/ubnt-wa)
+ DEVICE_MODEL := NanoBeam AC
+ DEVICE_VARIANT := Gen2
+ DEVICE_PACKAGES += kmod-ath10k-ct-smallbuffers ath10k-firmware-qca988x-ct rssileds
+endef
+TARGET_DEVICES += ubnt_nanobeam-ac-gen2
+
define Device/ubnt_nanobridge-m
$(Device/ubnt-xm)
SOC := ar7241