aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-09-22 12:06:25 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-06 21:28:49 +0200
commit794d4b66523f88ba7b420d973c8418c40d371a17 (patch)
tree1acadf1c78269af6221ca79e7e1b78f68e16137c /target/linux/ath79/image/generic-ubnt.mk
parent3b874c2c819f7ca87668e53f2b366a70d27eea61 (diff)
downloadupstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.gz
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.tar.bz2
upstream-794d4b66523f88ba7b420d973c8418c40d371a17.zip
treewide: remove kmod-usb-core from DEVICE_PACKAGES
This removes _all_ occurrences of kmod-usb-core from DEVICE_PACKAGES and similar variables. This package is pulled as dependency by one of the following packages in any case: - kmod-usb-chipidea - kmod-usb-dwc2 - kmod-usb-ledtrig-usbport - kmod-usb-ohci - kmod-usb2 - kmod-usb2-pci - kmod-usb3 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> [remove kmod-usb-core from EnGenius ESR600] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 4b2cee215c..6ae766e293 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -35,7 +35,7 @@ endef
# UBNT_VERSION e.g. one of (6.0.0, 8.5.0)
define Device/ubnt
DEVICE_VENDOR := Ubiquiti
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ DEVICE_PACKAGES := kmod-usb2
IMAGE_SIZE := 7552k
UBNT_BOARD := XM
UBNT_VERSION := 6.0.0
@@ -242,7 +242,7 @@ TARGET_DEVICES += ubnt_unifiac-mesh-pro
define Device/ubnt_unifiac-pro
$(Device/ubnt_unifiac)
DEVICE_MODEL := UniFi AC-Pro
- DEVICE_PACKAGES += kmod-usb-core kmod-usb2
+ DEVICE_PACKAGES += kmod-usb2
SUPPORTED_DEVICES += ubnt-unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-pro