aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorTobias Schramm <tobleminer@gmail.com>2020-01-01 10:01:48 +0100
committerDavid Bauer <mail@david-bauer.net>2020-01-14 09:38:32 +0100
commit66eb88edb66d49939bda444ff36ea4bf0aaf9ae1 (patch)
treeecdc9b1adda9e47513d7f4498f99f74485a325be /target/linux/ath79/image/generic-ubnt.mk
parent2e05d6185aca35e75f64ab63ddd822166712f6aa (diff)
downloadupstream-66eb88edb66d49939bda444ff36ea4bf0aaf9ae1.tar.gz
upstream-66eb88edb66d49939bda444ff36ea4bf0aaf9ae1.tar.bz2
upstream-66eb88edb66d49939bda444ff36ea4bf0aaf9ae1.zip
ath79: add support for Ubiquiti EdgeSwitch/ToughSwitch 5XP
The Ubiquiti ToughSwitch 5XP is a 5-port PoE Gigabit switch with a single Fast-Ethernet management port. It supports both 24V passive PoE out on all five ports. Flash: 8 MB RAM: 64 MB SoC: AR7242 Switch: ar8327 USB: 1x USB 2.0 Ethernet: 5x GbE, 1x FE Installation of the firmware is possible either via serial + tftpboot or the factory firmware update function via webinterface. By default the single Fast-Ethernet port labeled "MGMT" is configured as the WAN port. Thus access to the device is only possible via the five switch ports. Serial: 3v3 115200 8n1 The serial header is located in the lower left corner of the switches PCB: ``` | | | | o | o RX | o TX | o GND | | ++ +-++-+ ++ ++ + +--+ ++ +--++--++--+ ``` Signed-off-by: Tobias Schramm <tobleminer@gmail.com> [remove ubnt,sw compatible - fix spelling - wrap commit message - remove superfluous phy-mode property] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 87e7f5cc32..78364caffe 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -129,6 +129,12 @@ define Device/ubnt_bullet-m-xw
endef
TARGET_DEVICES += ubnt_bullet-m-xw
+define Device/ubnt_edgeswitch-5xp
+ $(Device/ubnt-sw)
+ DEVICE_MODEL := EdgeSwitch 5XP
+endef
+TARGET_DEVICES += ubnt_edgeswitch-5xp
+
define Device/ubnt_edgeswitch-8xp
$(Device/ubnt-sw)
DEVICE_MODEL := EdgeSwitch 8XP