aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorRussell Senior <russell@personaltelco.net>2020-03-10 18:06:02 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-18 13:45:57 +0100
commit572278d3a0390f1ad37eefab7fe86af5050d4199 (patch)
treefb8111779942997c3dc962407a811bdc1a85aac0 /target/linux/ath79/image/generic-ubnt.mk
parentdabe8471fc4ccc9297aa88148cdf527a4fca3576 (diff)
downloadupstream-572278d3a0390f1ad37eefab7fe86af5050d4199.tar.gz
upstream-572278d3a0390f1ad37eefab7fe86af5050d4199.tar.bz2
upstream-572278d3a0390f1ad37eefab7fe86af5050d4199.zip
ath79: generalize ubnt_xm dtsi for ar7240 and ar7241
* Prepare to support the AR7240 variant of ubiquiti bullet m, by reorganizing the related dtsi files. * Distribute SOC variable across ubnt-xm devices. Signed-off-by: Russell Senior <russell@personaltelco.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index a4aff09fec..aad177bf4a 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -71,7 +71,6 @@ endef
define Device/ubnt-xm
$(Device/ubnt)
- SOC := ar7241
DEVICE_VARIANT := XM
DEVICE_PACKAGES += kmod-usb-ohci
IMAGE_SIZE := 7448k
@@ -108,6 +107,7 @@ TARGET_DEVICES += ubnt_acb-isp
define Device/ubnt_airrouter
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := AirRouter
SUPPORTED_DEVICES += airrouter
endef
@@ -115,6 +115,7 @@ TARGET_DEVICES += ubnt_airrouter
define Device/ubnt_bullet-m
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := Bullet-M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
@@ -181,6 +182,7 @@ TARGET_DEVICES += ubnt_nanostation-ac-loco
define Device/ubnt_nanostation-loco-m
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := Nanostation Loco M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
@@ -197,6 +199,7 @@ TARGET_DEVICES += ubnt_nanostation-loco-m-xw
define Device/ubnt_nanostation-m
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := Nanostation M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += nanostation-m
@@ -213,6 +216,7 @@ TARGET_DEVICES += ubnt_nanostation-m-xw
define Device/ubnt_picostation-m
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := Picostation M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += bullet-m
@@ -221,6 +225,7 @@ TARGET_DEVICES += ubnt_picostation-m
define Device/ubnt_rocket-m
$(Device/ubnt-xm)
+ SOC := ar7241
DEVICE_MODEL := Rocket-M
DEVICE_PACKAGES += rssileds
SUPPORTED_DEVICES += rocket-m