aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-12-09 22:18:43 +0100
committerDavid Bauer <mail@david-bauer.net>2021-02-01 00:47:46 +0100
commit51f578efa5012464a21565556eaf2027b3d88ab5 (patch)
treec8ff97d6a79888b8511470b2c86b67ee76e022a2 /target/linux/ath79/image/generic-ubnt.mk
parent0c499f6068176c1139d5c6b7d89f454b03383453 (diff)
downloadupstream-51f578efa5012464a21565556eaf2027b3d88ab5.tar.gz
upstream-51f578efa5012464a21565556eaf2027b3d88ab5.tar.bz2
upstream-51f578efa5012464a21565556eaf2027b3d88ab5.zip
ath79: add support for Ubiquiti UniFi AP Outdoor+
Hardware -------- Atheros AR7241 16M SPI-NOR 64M DDR2 Atheros AR9283 2T2R b/g/n 2x Fast Ethernet (built-in) Installation ------------ Transfer the Firmware update to the device using SCP. Install using fwupdate.real -m <openwrt.bin> -d Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk30
1 files changed, 21 insertions, 9 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 91a18d3d35..733d803d7a 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -120,6 +120,18 @@ define Device/ubnt-xw
UBNT_VERSION := 6.0.4
endef
+define Device/ubnt-unifi-jffs2
+ $(Device/ubnt)
+ KERNEL_SIZE := 3072k
+ IMAGE_SIZE := 15744k
+ UBNT_TYPE := BZ
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
+ pad-rootfs | append-metadata | check-size
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
+endef
+
define Device/ubnt-acb
$(Device/ubnt)
IMAGE_SIZE := 15744k
@@ -420,19 +432,19 @@ define Device/ubnt_unifiac-pro
endef
TARGET_DEVICES += ubnt_unifiac-pro
+define Device/ubnt_unifi-ap-outdoor-plus
+ $(Device/ubnt-bz)
+ $(Device/ubnt-unifi-jffs2)
+ DEVICE_MODEL := UniFi AP Outdoor+
+ SUPPORTED_DEVICES += unifi-outdoor-plus
+endef
+TARGET_DEVICES += ubnt_unifi-ap-outdoor-plus
+
define Device/ubnt_unifi-ap-pro
+ $(Device/ubnt-unifi-jffs2)
SOC := ar9344
- DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := UniFi AP Pro
- UBNT_TYPE := BZ
UBNT_CHIP := ar934x
- KERNEL_SIZE := 3072k
- IMAGE_SIZE := 15744k
- KERNEL := kernel-bin | append-dtb | lzma | uImage lzma | jffs2 kernel0
- IMAGES := sysupgrade.bin factory.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs |\
- pad-rootfs | append-metadata | check-size
- IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
SUPPORTED_DEVICES += uap-pro
endef
TARGET_DEVICES += ubnt_unifi-ap-pro