aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-09-18 21:36:46 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-19 23:43:27 +0200
commit425e0bd19a72900e033387f45f4ab57e9f2611a5 (patch)
tree2704f9d8f77050385feba2bd0bf6fc267c7c8393 /target/linux/ath79/image/generic-ubnt.mk
parent7140394903b1bfbbb589dafa524e2dbd6cd79862 (diff)
downloadupstream-425e0bd19a72900e033387f45f4ab57e9f2611a5.tar.gz
upstream-425e0bd19a72900e033387f45f4ab57e9f2611a5.tar.bz2
upstream-425e0bd19a72900e033387f45f4ab57e9f2611a5.zip
ath79: add XM device variant for Ubiquiti devices
So far, XW devices have DEVICE_VARIANT defined and XM devices have no DEVICE_VARIANT set. This adds DEVICE_VARIANT for XM devices, and moves definitions for both XM and XW to the common definitions. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 368da8e01b..2e2e756514 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -46,6 +46,7 @@ endef
define Device/ubnt-xm
$(Device/ubnt)
+ DEVICE_VARIANT := XM
DEVICE_PACKAGES += kmod-usb-ohci rssileds
UBNT_TYPE := XM
UBNT_CHIP := ar7240
@@ -71,6 +72,7 @@ endef
define Device/ubnt-xw
$(Device/ubnt)
+ DEVICE_VARIANT := XW
UBNT_TYPE := XW
UBNT_CHIP := ar934x
UBNT_BOARD := XM
@@ -96,7 +98,6 @@ TARGET_DEVICES += ubnt_bullet-m
define Device/ubnt_bullet-m-xw
$(Device/ubnt-xw)
DEVICE_MODEL := Bullet-M
- DEVICE_VARIANT := XW
SUPPORTED_DEVICES += bullet-m-xw
endef
TARGET_DEVICES += ubnt_bullet-m-xw
@@ -118,7 +119,6 @@ TARGET_DEVICES += ubnt_nanostation-m
define Device/ubnt_nanostation-m-xw
$(Device/ubnt-xw)
DEVICE_MODEL := Nanostation M
- DEVICE_VARIANT := XW
SUPPORTED_DEVICES += nano-m-xw
endef
TARGET_DEVICES += ubnt_nanostation-m-xw