aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-10-22 13:08:23 +0200
committerJohn Crispin <john@phrozen.org>2019-10-27 14:02:27 +0100
commit3202ee0fc613fd786abf65b0093a81f6a0dbe036 (patch)
treec599e1002bffbc7aa54ba62c6b07d54785b0ee7b /target/linux/ath79/image/generic-ubnt.mk
parent3f275f2ac824da0f7e2005b54e308c30e1e55302 (diff)
downloadupstream-3202ee0fc613fd786abf65b0093a81f6a0dbe036.tar.gz
upstream-3202ee0fc613fd786abf65b0093a81f6a0dbe036.tar.bz2
upstream-3202ee0fc613fd786abf65b0093a81f6a0dbe036.zip
ath79: tidy up and fix IMAGE_SIZE for Ubiquiti devices
This addresses IMAGE_SIZE inconsistencies in generic_ubnt.mk by: 1. (cosmetical) Move IMAGE_SIZE out of top definition ("ubnt"), since despite two all subdefinition have different values. 2. (change) Fix IMAGE_SIZE for ubnt-xm and ubnt-bz (7552k->7488k). 3. (cosmetical) Move IMAGE_SIZE of ubnt-wa devices to parent node since all have same size (it is defined in parent DTSI ...). Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index ddf9f55d11..727025ba67 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -36,7 +36,6 @@ endef
define Device/ubnt
DEVICE_VENDOR := Ubiquiti
DEVICE_PACKAGES := kmod-usb2
- IMAGE_SIZE := 7552k
UBNT_BOARD := XM
UBNT_VERSION := 6.0.0
IMAGES += factory.bin
@@ -46,6 +45,7 @@ endef
define Device/ubnt-bz
$(Device/ubnt)
+ IMAGE_SIZE := 7448k
UBNT_TYPE := BZ
UBNT_CHIP := ar7240
ATH_SOC := ar7241
@@ -53,6 +53,7 @@ endef
define Device/ubnt-wa
$(Device/ubnt)
+ IMAGE_SIZE := 15744k
UBNT_TYPE := WA
UBNT_CHIP := ar934x
UBNT_BOARD := WA
@@ -64,6 +65,7 @@ define Device/ubnt-xm
$(Device/ubnt)
DEVICE_VARIANT := XM
DEVICE_PACKAGES += kmod-usb-ohci rssileds
+ IMAGE_SIZE := 7448k
UBNT_TYPE := XM
UBNT_CHIP := ar7240
ATH_SOC := ar7241
@@ -73,6 +75,7 @@ endef
define Device/ubnt-xw
$(Device/ubnt)
DEVICE_VARIANT := XW
+ IMAGE_SIZE := 7552k
UBNT_TYPE := XW
UBNT_CHIP := ar934x
UBNT_BOARD := XM
@@ -119,7 +122,6 @@ define Device/ubnt_lap-120
DEVICE_MODEL := LiteAP ac
DEVICE_VARIANT := LAP-120
DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_lap-120
@@ -128,7 +130,6 @@ define Device/ubnt_nanobeam-ac
$(Device/ubnt-wa)
DEVICE_MODEL := NanoBeam AC
DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_nanobeam-ac
@@ -137,7 +138,6 @@ define Device/ubnt_nanostation-ac
$(Device/ubnt-wa)
DEVICE_MODEL := Nanostation AC
DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_nanostation-ac
@@ -146,7 +146,6 @@ define Device/ubnt_nanostation-ac-loco
$(Device/ubnt-wa)
DEVICE_MODEL := Nanostation AC loco
DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15744k
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
endef
TARGET_DEVICES += ubnt_nanostation-ac-loco