aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2018-09-19 14:17:35 +0200
committerMathias Kresin <dev@kresin.me>2018-10-28 10:59:09 +0100
commit23f9b2d9a981c61b7166557febde31778d13b86f (patch)
tree09ab8b9e067cc8b20ae8c509700f889e2ad186d4 /target/linux/ath79/image/generic-ubnt.mk
parent8edce6014afa0d90ee3bd92739798e38c343e5d0 (diff)
downloadupstream-23f9b2d9a981c61b7166557febde31778d13b86f.tar.gz
upstream-23f9b2d9a981c61b7166557febde31778d13b86f.tar.bz2
upstream-23f9b2d9a981c61b7166557febde31778d13b86f.zip
ath79: Add support for Ubiquiti LiteAP ac (LAP-120)
This commit adds support for the Ubiquiti LiteAP ac (LAP-120), an outdoor 5 GHz AC access point with an integrated 120° 16 dBi antenna. The device was previously known as LiteBeam AP ac but was later rebranded. CPU: Atheros AR9342 SoC RAM: 64 MB DDR2 Flash: 16 MB NOR SPI Ports: 1 GbE port (PoE in) WLAN: 5 GHz QCA899X (PCI) The integrated QCA899X is a Ubiquiti branded part with modified vendor and product id (0777:11ac9). It is very similar to the NanoStation loco AC, except for the 2.4 GHz management radio (missing here). Installation procedure is the same as the NanoStation [loco] AC: 1. Connect to serial header on device 2. Power on device and enter uboot console 3. Set up tftp server serving an openwrt initramfs build 4. Load initramfs build using the command tftpboot in the uboot cli 5. Boot the loaded image using the command bootm 6. Copy squashfs openwrt sysupgrade build to the booted device 7. Use mtd to write sysupgrade to partition "firmware" 8. Reboot and enjoy Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 8cdd5a2d2f..bb86c8b288 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -84,6 +84,15 @@ define Device/ubnt_nano-m
endef
TARGET_DEVICES += ubnt_nano-m
+define Device/ubnt_lap-120
+ $(Device/ubnt-wa)
+ DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)
+ DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
+ IMAGE_SIZE := 15744k
+ IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
+endef
+TARGET_DEVICES += ubnt_lap-120
+
define Device/ubnt_nanostation-ac
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti Nanostation AC