aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2019-04-12 20:21:58 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2019-12-04 23:17:41 +0200
commit157e17e985ea494f7f0a870df0afa0a837eccb8c (patch)
treef48bf41214a88a9efcb4e271bc80ced054128165 /target/linux/ath79/image/generic-ubnt.mk
parentdb26f53bb353b8ddf3ad1ef3057eb59648a077e8 (diff)
downloadupstream-157e17e985ea494f7f0a870df0afa0a837eccb8c.tar.gz
upstream-157e17e985ea494f7f0a870df0afa0a837eccb8c.tar.bz2
upstream-157e17e985ea494f7f0a870df0afa0a837eccb8c.zip
ath79: add support for Ubiquiti LiteBeam AC Gen2
Hardware: * SoC: Atheros AR9342-BL1A * RAM: 64MB DDR2 (Winbond W9751G6KB-25) * Flash: 16MB SPI NOR (Macronix MX25L12835FZ2I-10G) * Ethernet: 1x 10/100/1000 Mbps (Atheros AR8035-A) with 24V PoE support * Wifi 2.4GHz: Atheros AR9340 v2 * WiFi 5GHz: Ubiquiti U-AME-G1-BR4A (rebranded QCA988X v2) * LEDs: 1x Power, 1x Ethernet * Buttons: 1x Reset * UART: 1x TTL 115200n8, 3.3V RX TX GND, 3.3V pin closest to RJ45 port The LEDs do not seem to be connected to any GPIO, so there is currently no way to control them. Installation via U-Boot, TFTP and serial console: * Configure your TFTP server with IP 192.168.1.254 * Connect serial console and power up the device * Hit any key to stop autoboot * tftpboot 0x81000000 openwrt-ath79-generic-ubnt_litebeam-ac-gen2-initramfs-kernel.bin * bootm 0x81000000 * copy openwrt-ath79-generic-ubnt_litebeam-ac-gen2-squashfs-sysupgrade.bin to /tmp * sysupgrade /tmp/openwrt-ath79-generic-ubnt_litebeam-ac-gen2-squashfs-sysupgrade.bin Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Petr Štetiar <ynezz@true.cz> Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 9f55a89d27..e75b9ea770 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -127,6 +127,14 @@ define Device/ubnt_lap-120
endef
TARGET_DEVICES += ubnt_lap-120
+define Device/ubnt_litebeam-ac-gen2
+ $(Device/ubnt-wa)
+ DEVICE_MODEL := LiteBeam AC
+ DEVICE_VARIANT := Gen2
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+endef
+TARGET_DEVICES += ubnt_litebeam-ac-gen2
+
define Device/ubnt_nanobeam-ac
$(Device/ubnt-wa)
DEVICE_MODEL := NanoBeam AC