aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-ubnt.mk
diff options
context:
space:
mode:
authorAndreas Ziegler <dev@andreas-ziegler.de>2019-10-06 19:48:34 +0200
committerDavid Bauer <mail@david-bauer.net>2019-10-15 18:13:54 +0200
commit07c1ddf522dbe6085af664cf03a41f636a70b99c (patch)
tree34f0d3956634e60cd0e9466d59a8d16258f3c17f /target/linux/ath79/image/generic-ubnt.mk
parent089b4f16aa3bec4b2231ca53cd4a3a0f4f6929a2 (diff)
downloadupstream-07c1ddf522dbe6085af664cf03a41f636a70b99c.tar.gz
upstream-07c1ddf522dbe6085af664cf03a41f636a70b99c.tar.bz2
upstream-07c1ddf522dbe6085af664cf03a41f636a70b99c.zip
ath79: add support for UniFi AC-LR
The Unifi AC-LR has identical hardware to the Unifi AC-Lite. The antenna setup is different according to the vendor, which explains the thicker enclosure. Therefore, it is helpful to know the exact device variant, instead of having "Ubiquiti UniFi-AC-LITE/LR". Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de> [fix legacy name in commit message; add old boardname to SUPPORTED_DEVICES] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/generic-ubnt.mk')
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 6ae766e293..984b18ccae 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -225,6 +225,13 @@ define Device/ubnt_unifiac-lite
endef
TARGET_DEVICES += ubnt_unifiac-lite
+define Device/ubnt_unifiac-lr
+ $(Device/ubnt_unifiac)
+ DEVICE_MODEL := UniFi AC-LR
+ SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
+endef
+TARGET_DEVICES += ubnt_unifiac-lr
+
define Device/ubnt_unifiac-mesh
$(Device/ubnt_unifiac)
DEVICE_MODEL := UniFi AC-Mesh