aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-03-11 18:50:42 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-03-11 22:00:26 +0100
commitdb91418766562fde7da468a19c87f25bc8aad8a0 (patch)
treea9c3e67e7bfe940c88c75cdbad25528918be8ae7 /target/linux/ath79/image/generic-tp-link.mk
parent82dbcd8bf2b472a962aa002d9c5cc2542608035a (diff)
downloadupstream-db91418766562fde7da468a19c87f25bc8aad8a0.tar.gz
upstream-db91418766562fde7da468a19c87f25bc8aad8a0.tar.bz2
upstream-db91418766562fde7da468a19c87f25bc8aad8a0.zip
ath79: add support for TP-Link RE350K v1
TP-Link RE350K v1 (FCC ID: TE7RE350K) is a wall-plug AC1200 Wi-Fi range extender with 'Kasa Smart' support. Device is based on Qualcomm/Atheros QCA9558 + QCA9882 + AR8035 platform and is available only on US market. Specification: - 720/600/200 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of flash (SPI NOR) - 1x 1 Gbps Ethernet (AR8035) - 2T2R 2.4 GHz (QCA9558), with ext. PA (SE2565T) and LNA (SKY65971-11) - 2T2R 5 GHz (QCA9882), with ext. PA (SE5003L1-R) and LNA (SKY65981-11) - 2x U.FL connector on PCB - 2x dual-band PCB antennas - 1x LED, 2x dual-color LED (all driven by GPIO) - 3x button (app config, led, reset) - 1x mechanical on/off slide switch - 1x UART (4-pin, 2.54 mm pitch) header on PCB - 1x JTAG (8-pin, 1.27 mm pitch) header on PCB Flash instruction: Use 'factory' image directly in vendor GUI (default IP: 192.168.0.254, default credentials: admin/admin). Warning: This device does not include any kind of recovery mechanism in U-Boot. Vendor firmware access: You can access vendor firmware over serial (RX line requires jumper resistor in R306 place, near XTAL) with: root/sohoadmin credentials. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 5933988632..e82a5a3073 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -109,6 +109,22 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_re350k-v1
+ $(Device/tplink)
+ ATH_SOC := qca9558
+ IMAGE_SIZE := 13760k
+ DEVICE_TITLE := TP-Link RE350K v1
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := RE350K-V1
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+ IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
+ check-size $$$$(IMAGE_SIZE) | append-metadata
+ IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+endef
+TARGET_DEVICES += tplink_re350k-v1
+
define Device/tplink_re450-v2
$(Device/tplink)
ATH_SOC := qca9563