aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAndrew Cameron <apcameron@softhome.net>2019-06-29 21:45:09 -0500
committerChristian Lamparter <chunkeey@gmail.com>2019-07-07 13:02:06 +0200
commitd5a38725f84f52618a7c4cb17e8bfac40a17854a (patch)
tree0e7931b13b381c609e1d716162797a5776d7b32f /target/linux/ath79/image/generic-tp-link.mk
parenta9deed62af569608af3e4e076138d788e24b1652 (diff)
downloadupstream-d5a38725f84f52618a7c4cb17e8bfac40a17854a.tar.gz
upstream-d5a38725f84f52618a7c4cb17e8bfac40a17854a.tar.bz2
upstream-d5a38725f84f52618a7c4cb17e8bfac40a17854a.zip
ath79: increase kernel partition size for CPE610v1
Increase the Kernel partition to address the issue discussed here https://forum.openwrt.org/t/cpe610-v1-sysupgrade-bin-missing-too-big/39637/5 Switch Back to the okli Loader to support increased partition size Signed-off-by: Andrew Cameron <apcameron@softhome.net> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [add <> for e-mail]
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index ec250a5404..f0d0a5cd07 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -167,7 +167,10 @@ define Device/tplink_cpe610-v1
DEVICE_VARIANT := v1
TPLINK_BOARD_ID := CPE610V1
LOADER_TYPE := elf
- KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
+ LOADER_FLASH_OFFS := 0x43000
+ COMPILE := loader-$(1).elf
+ COMPILE/loader-$(1).elf := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
endef
TARGET_DEVICES += tplink_cpe610-v1