aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-05-06 15:29:16 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-05-18 16:38:18 +0200
commitd4b89b7170ab82530cfaf21e5f00bee7088432e2 (patch)
treed03aab5ed32694c3230857e30c6d0ebe1b84c9a2 /target/linux/ath79/image/generic-tp-link.mk
parent78ea648a3a4efef6b953b6c5958dc569e59d94df (diff)
downloadupstream-d4b89b7170ab82530cfaf21e5f00bee7088432e2.tar.gz
upstream-d4b89b7170ab82530cfaf21e5f00bee7088432e2.tar.bz2
upstream-d4b89b7170ab82530cfaf21e5f00bee7088432e2.zip
ath79: Add support for TP-Link TL-WR1043N v5
Specifications: - QCA9563 at 775 MHz - 64 MB RAM Zentel A3R12E40CBF-8E - 16 MB flash Winbond W25Q128FVSG - 3 (non-detachable) Antennas / 450 Mbit - 1x/4x WAN/LAN Gbps Ethernet (QCA8337) - reset and Wi-Fi buttons TP-Link TL-WR1043N v5 appears to be identical to the TL-WR1043ND v4, except that the USB port has been removed and there is no longer a removable antenna option. It also has different partitioning scheme. The software is more in line with the Archer series in that it uses a nested bootloader scheme. (This has been adapted from the OpenWrt Wiki page) <https://openwrt.org/toh/tp-link/tl-wr1043nd> Installation on HW rev.5: Factory firmware can be installed via the WEB interface. Alternatively, it is also possible to use a TFTP server for recovery purposes: - Rename OpenWRT or original firmware to WR1043v5_tp_recovery.bin - Set static IP of your PC to *192.168.0.66* - Router will obtain IP 192.168.0.86 for a few seconds while loading, when reset button pressed at power On. And finally, there's always u-boot access through the UART. For information visit the wiki. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [reworked commit message]
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index b7b5d3e3cb..a3e1708fe1 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -285,6 +285,16 @@ define Device/tplink_tl-wr1043nd-v4
endef
TARGET_DEVICES += tplink_tl-wr1043nd-v4
+define Device/tplink_tl-wr1043n-v5
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 15104k
+ DEVICE_TITLE := TP-Link TL-WR1043N v5
+ TPLINK_BOARD_ID := TLWR1043NV5
+ SUPPORTED_DEVICES += tl-wr1043n-v5
+endef
+TARGET_DEVICES += tplink_tl-wr1043n-v5
+
define Device/tplink_tl-wr2543-v1
$(Device/tplink-8mlzma)
ATH_SOC := ar7242