aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAndrew Cameron <apcameron@softhome.net>2019-06-26 16:40:54 -0500
committerPetr Štetiar <ynezz@true.cz>2019-07-18 00:06:55 +0200
commitcad4132e003cecc386d791d552ddba42c182c216 (patch)
treea6f75df7a4fd997bc14e750c5a08621ad4880d8e /target/linux/ath79/image/generic-tp-link.mk
parent8e384ba8307742b54b2be326697a5dc2dec6880b (diff)
downloadupstream-cad4132e003cecc386d791d552ddba42c182c216.tar.gz
upstream-cad4132e003cecc386d791d552ddba42c182c216.tar.bz2
upstream-cad4132e003cecc386d791d552ddba42c182c216.zip
ath79: add support for TP-Link CPE510-v2/v3
TP-Link CPE510-v2/v3 is an outdoor wireless CPE for 5 GHz with one Ethernet port based on Atheros AR9344 Specifications: - Based on the same underlying hardware as the TP-Link CPE510 - Power, LAN, and 4 green LEDs - 1 10/100Mbps Shielded Ethernet Port (Passive PoE in) - Built-in 13dBi 2x2 dual-polarized directional MIMO antenna - Adjustable transmission power from 0 to 23dBm/200mw Flashing instructions: Flash factory image through stock firmware WEB UI or through TFTP To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP adress:192.168.0.254 Signed-off-by: Andrew Cameron <apcameron@softhome.net> [whitespace fixes] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index f1424d02ee..312ce78f22 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -159,6 +159,40 @@ define Device/tplink_cpe210-v3
endef
TARGET_DEVICES += tplink_cpe210-v3
+define Device/tplink_cpe510-v2
+ $(Device/tplink-safeloader)
+ ATH_SOC := ar9344
+ IMAGE_SIZE := 7680k
+ DEVICE_MODEL := CPE510
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE510V2
+ LOADER_TYPE := elf
+ LOADER_FLASH_OFFS := 0x43000
+ COMPILE := loader-$(1).elf
+ COMPILE/loader-$(1).elf := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
+ SUPPORTED_DEVICES += cpe510-v2
+endef
+TARGET_DEVICES += tplink_cpe510-v2
+
+define Device/tplink_cpe510-v3
+ $(Device/tplink-safeloader)
+ ATH_SOC := ar9344
+ IMAGE_SIZE := 7680k
+ DEVICE_MODEL := CPE510
+ DEVICE_VARIANT := v3
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE510V3
+ LOADER_TYPE := elf
+ LOADER_FLASH_OFFS := 0x43000
+ COMPILE := loader-$(1).elf
+ COMPILE/loader-$(1).elf := loader-okli-compile
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
+ SUPPORTED_DEVICES += cpe510-v3
+endef
+TARGET_DEVICES += tplink_cpe510-v3
+
define Device/tplink_cpe610-v1
$(Device/tplink-safeloader)
ATH_SOC := ar9344