aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorSander Vanheule <sander@svanheule.net>2020-07-26 22:40:54 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-12 19:37:24 +0200
commitc9f51a9ad6e8f99ed7adb78d208740b7d351985b (patch)
tree2ac82f84c562304068d1345b16fca19dd468bde4 /target/linux/ath79/image/generic-tp-link.mk
parent53df30f02beab977991431c6f687f5ac5d88999c (diff)
downloadupstream-c9f51a9ad6e8f99ed7adb78d208740b7d351985b.tar.gz
upstream-c9f51a9ad6e8f99ed7adb78d208740b7d351985b.tar.bz2
upstream-c9f51a9ad6e8f99ed7adb78d208740b7d351985b.zip
ath79: support for TP-Link EAP225-Wall v2
TP-Link EAP225-Wall v2 is an AC1200 (802.11ac Wave-2) wall plate access point. UART access and debricking require fine soldering. The device was kindly provided for porting by Stijn Segers. Device specifications: * SoC: QCA9561 @ 775MHz * RAM: 128MiB DDR2 * Flash: 16MiB SPI-NOR (GD25Q127CSIG) * Wireless 2.4GHz (SoC): b/g/n, 2x2 * Wireless 5Ghz (QCA9886): a/n/ac, 2x2 MU-MIMO * Ethernet (SoC): 4× 100Mbps * Eth0 (back): 802.3af/at PoE in * Eth1, Eth2 (bottom) * Eth3 (bottom): PoE out (can be toggled by GPIO) * One status LED * Two buttons (both work as failsafe) * LED button, implemented as KEY_BRIGHTNESS_TOGGLE * Reset button Flashing instructions, requires recent firmware (tested on 1.20.0): * ssh into target device and run `cliclientd stopcs` * Upgrade with factory image via web interface Debricking: * Serial port can be soldered on PCB J4 (1: TXD, 2: RXD, 3: GND, 4: VCC) * Bridge unpopulated resistors R162 (TXD) and R165 (RXD) Do NOT bridge R164 * Use 3.3V, 115200 baud, 8n1 * Interrupt bootloader by holding CTRL+B during boot * tftp initramfs to flash via sysupgrade or LuCI web interface MAC addresses: MAC address (as on device label) is stored in device info partition at an offset of 8 bytes. ath9k device has same address as ethernet, ath10k uses address incremented by 1. From OEM ifconfig: br0 Link encap:Ethernet HWaddr 50:...:04 eth0 Link encap:Ethernet HWaddr 50:...:04 wifi0 Link encap:UNSPEC HWaddr 50-...-04-... wifi1 Link encap:UNSPEC HWaddr 50-...-05-... Signed-off-by: Sander Vanheule <sander@svanheule.net> [fix IMAGE_SIZE] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index daf793671f..22d1ac8a9e 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -364,7 +364,6 @@ TARGET_DEVICES += tplink_cpe610-v2
define Device/tplink-eap2x5
$(Device/tplink-safeloader)
- SOC := qca9563
LOADER_TYPE := elf
KERNEL := kernel-bin | append-dtb | lzma | loader-kernel
KERNEL_INITRAMFS := $$(KERNEL)
@@ -372,8 +371,20 @@ define Device/tplink-eap2x5
pad-extra 128
endef
+define Device/tplink_eap225-wall-v2
+ $(Device/tplink-eap2x5)
+ SOC := qca9561
+ IMAGE_SIZE := 13824k
+ DEVICE_MODEL := EAP225-Wall
+ DEVICE_VARIANT := v2
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+ TPLINK_BOARD_ID := EAP225-WALL-V2
+endef
+TARGET_DEVICES += tplink_eap225-wall-v2
+
define Device/tplink_eap245-v3
$(Device/tplink-eap2x5)
+ SOC := qca9563
IMAGE_SIZE := 14592k
DEVICE_MODEL := EAP245
DEVICE_VARIANT := v3