aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-06-16 12:51:57 +0200
committerPetr Štetiar <ynezz@true.cz>2019-07-03 07:45:00 +0200
commitab02584685a5db880c0abe5a51d0213551e8728f (patch)
treeb01024583244d8cd1f9b089ea94df9cfca11cda2 /target/linux/ath79/image/generic-tp-link.mk
parent340df72e0745236379554dc9ff487e260a424465 (diff)
downloadupstream-ab02584685a5db880c0abe5a51d0213551e8728f.tar.gz
upstream-ab02584685a5db880c0abe5a51d0213551e8728f.tar.bz2
upstream-ab02584685a5db880c0abe5a51d0213551e8728f.zip
ath79: Use -v1 suffix for TP-Link WDR3600/4300
In ath79, identifiers tplink_tl-wdr3600 and tplink_tl-wdr4300 have been used while most other TP-Link devices include the revision. Although there actually is only one major revision of these devices, they bear the revision on their bottom (v1.x). TP-Link also refers to the devices as V1 on its web page. This patch thus adds -v1 to both so it is more consistent with other devices and with what you would expect from reading the on-device sticker and the support pages. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 73275ccf35..0ae82293bd 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -203,25 +203,25 @@ define Device/tplink_re450-v2
endef
TARGET_DEVICES += tplink_re450-v2
-define Device/tplink_tl-wdr3600
+define Device/tplink_tl-wdr3600-v1
$(Device/tplink-8mlzma)
ATH_SOC := ar9344
- DEVICE_TITLE := TP-Link TL-WDR3600
+ DEVICE_TITLE := TP-Link TL-WDR3600 v1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x36000001
SUPPORTED_DEVICES += tl-wdr4300
endef
-TARGET_DEVICES += tplink_tl-wdr3600
+TARGET_DEVICES += tplink_tl-wdr3600-v1
-define Device/tplink_tl-wdr4300
+define Device/tplink_tl-wdr4300-v1
$(Device/tplink-8mlzma)
ATH_SOC := ar9344
- DEVICE_TITLE := TP-Link TL-WDR4300
+ DEVICE_TITLE := TP-Link TL-WDR4300 v1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
TPLINK_HWID := 0x43000001
SUPPORTED_DEVICES += tl-wdr4300
endef
-TARGET_DEVICES += tplink_tl-wdr4300
+TARGET_DEVICES += tplink_tl-wdr4300-v1
define Device/tplink_tl-wdr4900-v2
$(Device/tplink-8mlzma)