aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2019-07-16 20:47:49 +0200
committerDavid Bauer <mail@david-bauer.net>2019-07-17 23:14:23 +0200
commit6fde0b735c455f834b1ffc10d38c24f056839b29 (patch)
tree4ca03c01aab370af54e3b1352ecd5d827733ba6a /target/linux/ath79/image/generic-tp-link.mk
parent8c51ddeff0876b439ac35a3f492ab719085bfb9c (diff)
downloadupstream-6fde0b735c455f834b1ffc10d38c24f056839b29.tar.gz
upstream-6fde0b735c455f834b1ffc10d38c24f056839b29.tar.bz2
upstream-6fde0b735c455f834b1ffc10d38c24f056839b29.zip
ath79: add support for TP-Link RE355 v1 and RE450 v1
Specification: SoC: Qualcomm Atheros QCA9558 RAM: 64/128MiB Flash: 8MiB SPI-NOR Wifi: - 2.4GHz: 3T3R (QCA9558) - 5GHz: 3T3R (QCA9880) LAN: 1x 10/100/1000 Mbps UART: - TP1: Tx - TP2: Rx - TP3: Gnd - TP4: 3v3 Flash instructions: Flash factory image through stock firmware WEB UI. Signed-off-by: Christoph Krapp <achterin@googlemail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 85d306a9b0..f1424d02ee 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -210,6 +210,33 @@ define Device/tplink_re350k-v1
endef
TARGET_DEVICES += tplink_re350k-v1
+define Device/tplink_rex5x-v1
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9558
+ IMAGE_SIZE := 6016k
+ DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+endef
+
+define Device/tplink_re355-v1
+ $(Device/tplink_rex5x-v1)
+ DEVICE_MODEL := RE355
+ DEVICE_VARIANT := v1
+ TPLINK_BOARD_ID := RE355
+ SUPPORTED_DEVICES += re355
+endef
+TARGET_DEVICES += tplink_re355-v1
+
+define Device/tplink_re450-v1
+ $(Device/tplink_rex5x-v1)
+ DEVICE_MODEL := RE450
+ DEVICE_VARIANT := v1
+ TPLINK_BOARD_ID := RE450
+ SUPPORTED_DEVICES += re450
+endef
+TARGET_DEVICES += tplink_re450-v1
+
define Device/tplink_re450-v2
$(Device/tplink-safeloader)
ATH_SOC := qca9563