aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2019-12-01 19:31:32 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-19 15:40:40 +0100
commit60de1fdbb4492b5270edf49d634979c0cfd1e743 (patch)
tree593b78097cd0294fcc7119f913f46916e9343b65 /target/linux/ath79/image/generic-tp-link.mk
parentebf535a6cfefef5b0afb74cb01c9a17ab242b85b (diff)
downloadupstream-60de1fdbb4492b5270edf49d634979c0cfd1e743.tar.gz
upstream-60de1fdbb4492b5270edf49d634979c0cfd1e743.tar.bz2
upstream-60de1fdbb4492b5270edf49d634979c0cfd1e743.zip
ath79: add support for TP-Link TL-WR902AC v1
TP-Link TL-WR902AC v1 is a pocket-size, dual-band (AC750), successor of TL-MR3020 (both devices use very similar enclosure, in same size). New device is based on Qualcomm QCA9531 v2 + QCA9887. FCC ID: TE7WR902AC. Specification: - 650/391/216 MHz (CPU/DDR/AHB) - 1x 10/100 Mbps Ethernet - 1x USB 2.0 (GPIO-controlled power) - 64 MB of RAM (DDR2) - 8 MB of FLASH - 2T2R 2.4 GHz (QCA9531) - 1T1R 5 GHz (QCA9887) - 5x LED (GPIO-controlled), 2x button, 1x 3-pos switch - UART pads on PCB (TP1 -> TX, TP2 -> RX, TP3 -> GND, TP4 -> 3V3, jumper resitors are missing on TX/RX lines) - 1x micro USB (for power only) Flash instructions: Use "factory" image under vendor GUI. Recovery instructions: This device contains tftp recovery mode inside U-Boot. You can use it to flash OpenWrt (use "factory" image) or vendor firmware. 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "openwrt-ath79-generic-tplink_tl-wr902ac-v1-squashfs-factory.bin" to "wr902acv1_un_tp_recovery.bin" and place it in tftp server dir. 3. Connect PC with LAN port, press the reset button, power up the router and keep button pressed until WPS LED lights up. 4. Router will download file from server, write it to flash and reboot. MAC Address summary: - wlan1 (2.4GHz Wi-Fi): Label MAC - wlan0 (5GHz Wi-Fi): Offset -1 from label - eth0 (Wired): Offset +1 from label Root access over serial line in vendor firmware: root/sohoadmin. Based on support in ar71xx target by: Piotr Dymacz <pepe2k@gmail.com> Signed-off-by: Lech Perczak <lech.perczak@gmail.com> [remove size-cells from gpio-export] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 8915552322..c43927e19b 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -563,6 +563,21 @@ define Device/tplink_tl-wr842n-v3
endef
TARGET_DEVICES += tplink_tl-wr842n-v3
+define Device/tplink_tl-wr902ac-v1
+ $(Device/tplink-safeloader)
+ ATH_SOC := qca9531
+ DEVICE_MODEL := TL-WR902AC
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport \
+ kmod-ath10k-ct ath10k-firmware-qca9887-ct -swconfig -uboot-envtools
+ TPLINK_BOARD_ID := TL-WR902AC-V1
+ IMAGE_SIZE := 7360k
+ TPLINK_HWID := 0x0
+ TPLINK_HWREV := 0
+ SUPPORTED_DEVICES += tl-wr902ac-v1
+endef
+TARGET_DEVICES += tplink_tl-wr902ac-v1
+
define Device/tplink_wbs210-v2
$(Device/tplink-loader-okli)
ATH_SOC := ar9344