aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorOldřich Jedlička <oldium.pro@gmail.com>2019-01-01 23:11:49 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-02-05 19:37:31 +0100
commit12310f05b7b080b016ec515796be437f4cd30b62 (patch)
tree12884b879bce3ca5cb6ef433ffd128143ceee70d /target/linux/ath79/image/generic-tp-link.mk
parentbb23cb1bf2a32d1441720ae50bc354b8811b4bc7 (diff)
downloadupstream-12310f05b7b080b016ec515796be437f4cd30b62.tar.gz
upstream-12310f05b7b080b016ec515796be437f4cd30b62.tar.bz2
upstream-12310f05b7b080b016ec515796be437f4cd30b62.zip
ath79: add support for TP-LINK Archer C7 v4
TP-Link Archer C7 v4 is a dual-band AC1750 router, based on the Qualcomm/Atheros QCA9561 SoC + QCA9880. Specification: - 775/650/258 MHz (CPU/DDR/AHB) - 128 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 3T3R 5 GHz - 5x 10/100/1000 Mbps Ethernet - 7x LED, 2x button - UART header on PCB Flash instruction: 1. Upload openwrt-ath79-generic-tplink_archer-c7-v4-squashfs-factory.bin via Web interface Flash instruction using TFTP recovery: 1. Set PC to fixed ip address 192.168.0.66 2. Download openwrt-ath79-generic-tplink_archer-c7-v4-squashfs-factory.bin and rename it to ArcherC7v4_tp_recovery.bin 3. Start a tftp server with the file tp_recovery.bin in its root directory 4. Turn off the router 5. Press and hold Reset button 6. Turn on router with the reset button pressed and wait ~15 seconds 7. Release the reset button and after a short time the firmware should be transferred from the tftp server 8. Wait ~30 second to complete recovery. Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 52a181c353..4208878210 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -75,6 +75,18 @@ define Device/tplink_archer-c7-v2
endef
TARGET_DEVICES += tplink_archer-c7-v2
+define Device/tplink_archer-c7-v4
+ $(Device/tplink-safeloader-uimage)
+ ATH_SOC := qca9563
+ IMAGE_SIZE := 15104k
+ DEVICE_TITLE := TP-LINK Archer C7 v4
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ TPLINK_BOARD_ID := ARCHER-C7-V4
+ BOARDNAME := ARCHER-C7-V4
+ SUPPORTED_DEVICES += archer-c7-v4
+endef
+TARGET_DEVICES += tplink_archer-c7-v4
+
define Device/tplink_archer-c7-v5
$(Device/tplink-safeloader-uimage)
ATH_SOC := qca9563