aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-20 12:01:14 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-07 18:04:03 +0200
commit08857e69becc214336ba073bca6f626bfaa67781 (patch)
treeaf098ae63130c0a926573480e66db02abfe07c27 /target/linux/ath79/image/generic-tp-link.mk
parent198eae28623e9e422fe3b52ac53632fab980a561 (diff)
downloadupstream-08857e69becc214336ba073bca6f626bfaa67781.tar.gz
upstream-08857e69becc214336ba073bca6f626bfaa67781.tar.bz2
upstream-08857e69becc214336ba073bca6f626bfaa67781.zip
ath79: add support for TP-Link CPE210 v1
Specifications: * SoC: Qualcomm Atheros AR9344 (560 MHz) * RAM: 64MB * Storage: 8 MB * Wireless: 2.4GHz N based built into SoC 2x2 * Ethernet: 2x 100/10 Mbps, integrated into SoC, 24V POE IN Installation: Flash factory image through stock firmware WEB UI or through TFTP: To get to TFTP recovery just hold reset button while powering on for around 4-5 seconds and release. Rename factory image to recovery.bin Stock TFTP server IP:192.168.0.100 Stock device TFTP address:192.168.0.254 Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 006831ff52..a5844227e4 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -157,6 +157,18 @@ define Device/tplink_archer-c7-v5
endef
TARGET_DEVICES += tplink_archer-c7-v5
+define Device/tplink_cpe210-v1
+ $(Device/tplink-loader-okli)
+ ATH_SOC := ar9344
+ IMAGE_SIZE := 7680k
+ DEVICE_MODEL := CPE210
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := rssileds
+ TPLINK_BOARD_ID := CPE210
+ SUPPORTED_DEVICES += cpe210
+endef
+TARGET_DEVICES += tplink_cpe210-v1
+
define Device/tplink_cpe210-v2
$(Device/tplink-safeloader)
ATH_SOC := qca9533