aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/generic-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 15:42:48 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-23 16:09:58 +0100
commit07ce940b77e6aceb095b0a16dda41e190dfc5b87 (patch)
tree82ab93a5bfa55711ab5ab5b597cb8915ef4b8f5e /target/linux/ath79/image/generic-tp-link.mk
parent071a6372762d289b2fa5a8d1a138eff944c93c9e (diff)
downloadupstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.tar.gz
upstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.tar.bz2
upstream-07ce940b77e6aceb095b0a16dda41e190dfc5b87.zip
ath79: fix SUPPORTED_DEVICES not matching ar71xx board names
Based on a script for comparison, this fixes (hopefully) all errors in SUPPORTED_DEVICES for ar71xx->ath79 upgrade. Devices where old string is removed as the device does not exist in ar71xx: - dlink_dir-859-a1 - tplink_archer-a7-v5 - tplink_cpe510-v3 Devices where string is changed because it did not match the board name in ar71xx: - tplink_tl-mr3220-v1 - tplink_tl-mr3420-v1 - tplink_tl-wr2543-v1 - tplink_tl-wr741nd-v4 - tplink_tl-wr841-v7 - ubnt_unifiac-mesh - ubnt_unifiac-mesh-pro - ubnt_unifiac-pro For this device, the correct string could not be found, but we could not determine the correct one. Thus, the string is removed for now: - tplink_tl-wr740n-v4 The script for checking this is quite simple (note that newer entries, i.e. ath79->ath79 upgrade, are displayed as missing): newpath=target/linux/ath79/image/ oldpath=target/linux/ar71xx/base-files/lib/ar71xx.sh for s in $(grep -roh "SUPPORTED_DEVICES.*" $newpath | sed 's/SUPPORTED_DEVICES *.= *//'); do found="Missing" grep -q -r "\"$s\"" $oldpath && found="Found" echo "$s: $found." done The errors might be filtered by appending 'grep "Missing"' to the script. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/generic-tp-link.mk')
-rw-r--r--target/linux/ath79/image/generic-tp-link.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/ath79/image/generic-tp-link.mk b/target/linux/ath79/image/generic-tp-link.mk
index 53138e343b..7ac27759cc 100644
--- a/target/linux/ath79/image/generic-tp-link.mk
+++ b/target/linux/ath79/image/generic-tp-link.mk
@@ -10,7 +10,6 @@ define Device/tplink_archer-a7-v5
ath10k-firmware-qca988x-ct
TPLINK_BOARD_ID := ARCHER-A7-V5
BOARDNAME := ARCHER-A7-V5
- SUPPORTED_DEVICES += archer-a7-v5
endef
TARGET_DEVICES += tplink_archer-a7-v5
@@ -306,7 +305,6 @@ define Device/tplink_cpe510-v3
DEVICE_VARIANT := v3
DEVICE_PACKAGES := rssileds
TPLINK_BOARD_ID := CPE510V3
- SUPPORTED_DEVICES += cpe510-v3
endef
TARGET_DEVICES += tplink_cpe510-v3
@@ -517,7 +515,7 @@ define Device/tplink_tl-wr2543-v1
IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -v 3.13.99 | \
append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := tplink-v1-image factory -v 3.13.99
- SUPPORTED_DEVICES += tl-wr2543-v1
+ SUPPORTED_DEVICES += tl-wr2543n
endef
TARGET_DEVICES += tplink_tl-wr2543-v1