aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-tp-link.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-06-29 01:07:00 +0200
committerDavid Bauer <mail@david-bauer.net>2020-06-29 01:08:09 +0200
commitf49063ba9214cd679bd9b0d5504eadd5d6d86d4e (patch)
tree3e6163594017921b7fd2a118d3d34144f84bac92 /target/linux/ath79/image/common-tp-link.mk
parentdbaf0d20bb6afec4a592456af6b1238b46fa1acb (diff)
downloadupstream-f49063ba9214cd679bd9b0d5504eadd5d6d86d4e.tar.gz
upstream-f49063ba9214cd679bd9b0d5504eadd5d6d86d4e.tar.bz2
upstream-f49063ba9214cd679bd9b0d5504eadd5d6d86d4e.zip
ath79: replace custom uImageArcher generation
The replaces the custom uImageArcher build step with the generic uImage build step. The only different between these two is the difference in the generated name. Tested on: TP-Link Archer C59 v1 Acked-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ath79/image/common-tp-link.mk')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk10
1 files changed, 1 insertions, 9 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 3ae377f78f..0b7b0e1935 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -1,14 +1,6 @@
DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION
DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HWREVADD TPLINK_HVERSION
-define Build/uImageArcher
- mkimage -A $(LINUX_KARCH) \
- -O linux -T kernel -C $(1) -a $(KERNEL_LOADADDR) \
- -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
- @mv $@.new $@
-endef
-
define Device/tplink-v1
DEVICE_VENDOR := TP-Link
TPLINK_HWID := 0x0
@@ -88,7 +80,7 @@ endef
define Device/tplink-safeloader-uimage
$(Device/tplink-safeloader)
- KERNEL := kernel-bin | append-dtb | lzma | uImageArcher lzma
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := $$(KERNEL)
endef