aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-31 13:57:50 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-08 16:15:29 +0100
commit9b0e8d0aa464f51460ff33179e247f1071564471 (patch)
tree33e645666af3830d8aeb36a2a256ba1450bb9f00 /target/linux/ath79/image/common-tp-link.mk
parent0c97f034c9c5810096b022e2decea58fd4a4fae1 (diff)
downloadupstream-9b0e8d0aa464f51460ff33179e247f1071564471.tar.gz
upstream-9b0e8d0aa464f51460ff33179e247f1071564471.tar.bz2
upstream-9b0e8d0aa464f51460ff33179e247f1071564471.zip
treewide: move mktplinkfw to tplink-v1-image in image-commands.mk
This move the slightly different target-specific implementations of mktplinkfw from the targets to include/image-commands.mk and renames it to tplink-v1-image. Having a common version will increase consistency between implementation and will complete the tplink build command already present in the new location. Due to the slight differences of the original implementations, this also does some adjustments to the device build commands/variables. This also moves rootfs_align as this is required as dependency. Tested on: - TL-WDR4300 v1 (ath79, factory) - TL-WDR4900 v1 (mpc85xx, sysupgrade) - RE210 v1 (ramips, see Tested-by) Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Christoph Krapp <achterin@googlemail.com>
Diffstat (limited to 'target/linux/ath79/image/common-tp-link.mk')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk27
1 files changed, 2 insertions, 25 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index 0dc58191a8..1c7ff0e567 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -1,28 +1,6 @@
DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION
DEVICE_VARS += TPLINK_BOARD_NAME TPLINK_BOARD_ID
-define rootfs_align
-$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))
-endef
-
-# combine kernel and rootfs into one image
-# mktplinkfw <type> <optional extra arguments to mktplinkfw binary>
-# <type> is "sysupgrade" or "factory"
-#
-# -a align the rootfs start on an <align> bytes boundary
-# -j add jffs2 end-of-filesystem markers
-# -s strip padding from end of the image
-# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
-define Build/mktplinkfw
- -$(STAGING_DIR_HOST)/bin/mktplinkfw \
- -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) \
- -N OpenWrt -V $(REVISION) -m $(TPLINK_HEADER_VERSION) \
- -k $(IMAGE_KERNEL) -r $@ -o $@.new -j -X 0x40000 \
- -a $(call rootfs_align,$(FILESYSTEM)) \
- $(wordlist 2,$(words $(1)),$(1)) \
- $(if $(findstring sysupgrade,$(word 1,$(1))),-s) && mv $@.new $@ || rm -f $@
-endef
-
# mktplinkfw-combined
#
# -c combined image
@@ -50,9 +28,8 @@ define Device/tplink
KERNEL := kernel-bin | append-dtb | lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | tplink-v1-header
IMAGES += factory.bin
- IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade | \
- append-metadata
- IMAGE/factory.bin := append-rootfs | mktplinkfw factory
+ IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade | append-metadata
+ IMAGE/factory.bin := tplink-v1-image factory
endef
define Device/tplink-nolzma