aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-tp-link.mk
diff options
context:
space:
mode:
authorPeter Lundkvist <peter.lundkvist@gmail.com>2018-06-29 05:44:58 +0200
committerJohn Crispin <john@phrozen.org>2018-07-02 07:05:33 +0200
commit781ad46206ddaee74e40d7dbc68840fae1c0cc7c (patch)
treeca8ec054dcd0fac6531bdb74dda5316267ecce96 /target/linux/ath79/image/common-tp-link.mk
parentf4ac88b5097685950c6f6ba0077840f85446389f (diff)
downloadupstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.tar.gz
upstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.tar.bz2
upstream-781ad46206ddaee74e40d7dbc68840fae1c0cc7c.zip
ath79: add support for TP-Link RE450 v2
TP-Link RE450 v2 is a dual band router/range-extender based on Qualcomm/Atheros QCA9563 + QCA9880. Specification: - 775 MHz CPU - 64 MB of RAM (DDR2) - 8 MB of FLASH (SPI NOR) - 3T3R 2.4 GHz - 3T3R 5 GHz - 1x 10/100/1000 Mbps Ethernet (AR8033 PHY) - 7x LED, 4x button - UART header on PCB (needs unmounted R64 & R69 0201 resistors/jumpers) Flash instruction: Apply factory image in OEM firmware web-gui. U-Boot does not seem to have any recovery functions, so debricking requires connection via UART. Signed-off-by: Peter Lundkvist <peter.lundkvist@gmail.com>
Diffstat (limited to 'target/linux/ath79/image/common-tp-link.mk')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index f816308a9d..7490aeb1f3 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -1,4 +1,4 @@
-DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME
+DEVICE_VARS += TPLINK_HWID TPLINK_HWREV TPLINK_FLASHLAYOUT TPLINK_HEADER_VERSION TPLINK_BOARD_NAME TPLINK_BOARD_ID
define rootfs_align
$(patsubst %-256k,0x40000,$(patsubst %-128k,0x20000,$(patsubst %-64k,0x10000,$(patsubst squashfs%,0x4,$(patsubst root.%,%,$(1))))))