aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-tp-link.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-10-22 13:08:24 +0200
committerJohn Crispin <john@phrozen.org>2019-10-27 14:02:43 +0100
commit4b4856bc53ad4ce272588a4822e7bfab993d73e1 (patch)
treeffcf8559e245754dfa172006d78ee280249c2ac8 /target/linux/ath79/image/common-tp-link.mk
parent3202ee0fc613fd786abf65b0093a81f6a0dbe036 (diff)
downloadupstream-4b4856bc53ad4ce272588a4822e7bfab993d73e1.tar.gz
upstream-4b4856bc53ad4ce272588a4822e7bfab993d73e1.tar.bz2
upstream-4b4856bc53ad4ce272588a4822e7bfab993d73e1.zip
ath79: fix IMAGE_SIZE for common TP-Link definitions
So far, IMAGE_SIZE is set as follows: tplink-4m* 3904k 0x3d0000 tplink-8m* 7936k 0x7c0000 tplink-16m* 15872k 0xf80000 However, based on the size of firmware partitions in DTS it should be: tplink-4m* 3904k 0x3d0000 tplink-8m* 8000k 0x7d0000 tplink-16m* 16192k 0xfd0000 All (!) 8m*/16m* devices actually follow the latter scheme, which is also consistent in terms of left free space for other partitions. Thus, fix it. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/common-tp-link.mk')
-rw-r--r--target/linux/ath79/image/common-tp-link.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ath79/image/common-tp-link.mk b/target/linux/ath79/image/common-tp-link.mk
index d1d4a8940d..bda81a3e2b 100644
--- a/target/linux/ath79/image/common-tp-link.mk
+++ b/target/linux/ath79/image/common-tp-link.mk
@@ -83,19 +83,19 @@ endef
define Device/tplink-8m
$(Device/tplink-nolzma)
TPLINK_FLASHLAYOUT := 8M
- IMAGE_SIZE := 7936k
+ IMAGE_SIZE := 8000k
endef
define Device/tplink-8mlzma
$(Device/tplink)
TPLINK_FLASHLAYOUT := 8Mlzma
- IMAGE_SIZE := 7936k
+ IMAGE_SIZE := 8000k
endef
define Device/tplink-16mlzma
$(Device/tplink)
TPLINK_FLASHLAYOUT := 16Mlzma
- IMAGE_SIZE := 15872k
+ IMAGE_SIZE := 16192k
endef
define Device/tplink-safeloader