aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/common-buffalo.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-08-22 14:34:45 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-09-21 22:17:39 +0200
commitd1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e (patch)
treea2614da6820e57eb436289d821f7f9a06fa0ee86 /target/linux/ath79/image/common-buffalo.mk
parent4fc0a61ed3da96330d30703a2a039a6a06dc0b2f (diff)
downloadupstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.tar.gz
upstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.tar.bz2
upstream-d1e3f32dcf63d19dcfe5cb4a1d8437e7a55cb96e.zip
ath79: sort device definitions in image/*
This applies alphabetic sorting to devices in image/* files. For certain cases, this patch deviates from strict sorting, e.g. to ensure that v10 comes after v9. While at it, fix an indent and remove some useless empty lines. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/common-buffalo.mk')
-rw-r--r--target/linux/ath79/image/common-buffalo.mk16
1 files changed, 7 insertions, 9 deletions
diff --git a/target/linux/ath79/image/common-buffalo.mk b/target/linux/ath79/image/common-buffalo.mk
index 8870af691e..d62b7eea94 100644
--- a/target/linux/ath79/image/common-buffalo.mk
+++ b/target/linux/ath79/image/common-buffalo.mk
@@ -1,11 +1,3 @@
-define Build/buffalo-tftp-header
- ( \
- echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
- dd if=$@; \
- ) > $@.new
- mv $@.new $@
-endef
-
define Build/buffalo-tag
$(eval product=$(word 1,$(1)))
$(eval hwver=$(word 2,$(1)))
@@ -18,4 +10,10 @@ define Build/buffalo-tag
mv $@.new $@
endef
-
+define Build/buffalo-tftp-header
+ ( \
+ echo -n -e "# Airstation Public Fmt1" | dd bs=32 count=1 conv=sync; \
+ dd if=$@; \
+ ) > $@.new
+ mv $@.new $@
+endef