aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-05-07 22:41:04 +0200
committerMathias Kresin <dev@kresin.me>2018-05-17 07:40:19 +0200
commitf7ec385c1381db731cd5f1d22fe31149ffcbbb5e (patch)
treed6d54c02093558fa29f09033497baef67e97074f /target/linux/ath79/image/Makefile
parentf77db1a59036d896139e6cddcdb62bf38f2f9ff6 (diff)
downloadupstream-f7ec385c1381db731cd5f1d22fe31149ffcbbb5e.tar.gz
upstream-f7ec385c1381db731cd5f1d22fe31149ffcbbb5e.tar.bz2
upstream-f7ec385c1381db731cd5f1d22fe31149ffcbbb5e.zip
ath79: add and enforce image metadata
Add metadata to images and make the metdata mandatory. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 9c789d4e0f..cbd205bc78 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -62,8 +62,10 @@ define Device/Default
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
COMPILE :=
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
ifeq ($(SUBTARGET),generic)