aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 21:01:32 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 22:25:53 +0200
commitc57e182b560e4c93377270d470600095c2b580fe (patch)
treef8c6eb4387902378e6bad9d3dbd5abbfa1a79d27 /target/linux/ath79/image/Makefile
parent108a6f6792bc50fa5b1627c207ae71ba555b55f8 (diff)
downloadupstream-c57e182b560e4c93377270d470600095c2b580fe.tar.gz
upstream-c57e182b560e4c93377270d470600095c2b580fe.tar.bz2
upstream-c57e182b560e4c93377270d470600095c2b580fe.zip
ath79: lzma-loader: sync with ar71xx target
Import all improvements made in the lzma-loader since development on the ath79 target started. This also reverts fe594bf90d09 ("ath79: fix loader-okli, lzma-loader"), as is obsoleted by 2ad60168b6af ("ar71xx: lzma-loader: move padding workaround to gzip step"). Likely, many of the changes should be ported to the ramips lzma-loader as well, but I don't have a device to test this. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index cd136b23b9..34dd819610 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -29,8 +29,9 @@ define Build/loader-okli-compile
$(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
endef
+# Arguments: <output name> <kernel offset>
define Build/loader-okli
- dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
+ dd if=$(KDIR)/loader-$(word 1,$(1)).$(LOADER_TYPE) bs=$(word 2,$(1)) conv=sync of="$@.new"
cat "$@" >> "$@.new"
mv "$@.new" "$@"
endef