aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2021-05-08 17:34:30 -0400
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-05-16 13:05:42 +0200
commitbf8c16dfa2cddd529f889510ca5fa5160606c325 (patch)
tree7c3673b419365404abe421da92a324f0b2829809 /target/linux/ath79/image/Makefile
parent23f98b3eb7ab34b66896c5eae7695c22cc24cd39 (diff)
downloadupstream-bf8c16dfa2cddd529f889510ca5fa5160606c325.tar.gz
upstream-bf8c16dfa2cddd529f889510ca5fa5160606c325.tar.bz2
upstream-bf8c16dfa2cddd529f889510ca5fa5160606c325.zip
ath79: set lzma-loader variables to null by default
This fixes a small regression where the lzma-loader variable values are being shared between boards that require different configurations. If not set to "" globally, a device without these settings will just take the last values another device has set before in the queue. Fixes: 1b8bd17c2d07 ("ath79: lzma-loader: allow setting custom kernel magic") Signed-off-by: Michael Pratt <mcpratt@pm.me> [add detailed explanation to the commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index d8b8800d91..3c126f479e 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -70,6 +70,10 @@ define Device/Default
BLOCKSIZE := 64k
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ LOADER_KERNEL_MAGIC :=
+ LOADER_FLASH_MAX :=
+ LOADER_FLASH_OFFS :=
+ LOADER_TYPE :=
COMPILE :=
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \