aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-07 13:11:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-11 01:44:13 +0200
commitbb39fea11aae2888e6a0129055de21995da92073 (patch)
tree5dcca668bad0414fc458db065424b4ecc456e20a /target/linux/ath79/image/Makefile
parent108df3eabbb4dd93ff3c616c9455d69daaa98b49 (diff)
downloadupstream-bb39fea11aae2888e6a0129055de21995da92073.tar.gz
upstream-bb39fea11aae2888e6a0129055de21995da92073.tar.bz2
upstream-bb39fea11aae2888e6a0129055de21995da92073.zip
treewide: simplify inclusion of subtarget image files
Many target use a repetitive if-include scheme for their subtarget image files, though their names are consistent with the subtarget names. This patch removes these redundant conditions and just uses the variable for the include where the target setup allows it. For sunxi, this includes a trivial rename of the subtarget image Makefiles. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 529baf8f57..a555cfc6d5 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -68,20 +68,16 @@ define Device/Default
append-rootfs | pad-rootfs | append-metadata | check-size
endef
+include $(SUBTARGET).mk
+
ifeq ($(SUBTARGET),generic)
-include ./generic.mk
-include ./generic-tp-link.mk
-include ./generic-ubnt.mk
-endif
-ifeq ($(SUBTARGET),mikrotik)
-include ./mikrotik.mk
-endif
-ifeq ($(SUBTARGET),nand)
-include ./nand.mk
+include generic-tp-link.mk
+include generic-ubnt.mk
endif
+
ifeq ($(SUBTARGET),tiny)
-include ./tiny.mk
-include ./tiny-netgear.mk
-include ./tiny-tp-link.mk
+include tiny-netgear.mk
+include tiny-tp-link.mk
endif
+
$(eval $(call BuildImage))