aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2020-02-28 16:01:02 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-17 11:50:47 +0100
commita66eee63368eb5625b359244bfffc9b9eb921875 (patch)
tree6a76e6a9d54527f8a41b41fa80fbc40d30a240ee /target/linux/ath79/image/Makefile
parentb78f61c336542a3658c3b1c595b3bb2810f93500 (diff)
downloadupstream-a66eee63368eb5625b359244bfffc9b9eb921875.tar.gz
upstream-a66eee63368eb5625b359244bfffc9b9eb921875.tar.bz2
upstream-a66eee63368eb5625b359244bfffc9b9eb921875.zip
ath79: add mikrotik subtarget
This commit creates the ath79/mikrotik subtarget in order to support MikroTik devices based on Qualcomm Atheros MIPS SoCs. MikroTik devices need a couple of specific features: the split MiNOR firmware MTD format, which is not used by other devices, and the 4k sector erase size on SPI NOR storage, which can not be added to the ath79/generic and ath79/nand subtargets now. Additionally, the commit moves the two MikroTik devices already in the generic and nand subtargets to this new one. Tested on the RB922 board and the wAP AC router. Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index c27db93947..c568c7238c 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -73,6 +73,9 @@ include ./generic.mk
include ./generic-tp-link.mk
include ./generic-ubnt.mk
endif
+ifeq ($(SUBTARGET),mikrotik)
+include ./mikrotik.mk
+endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk
endif