aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2020-12-01 18:30:27 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-12-01 20:03:15 +0100
commit760952ad022561931846b02ddfe69c21afead0fe (patch)
treed9f9c2fbee7bfc6b97414a9e709b900c9718edcb /target/linux/ath79/image/Makefile
parent474aa3237c1bac86b475c3b2955e9501353a87f5 (diff)
downloadupstream-760952ad022561931846b02ddfe69c21afead0fe.tar.gz
upstream-760952ad022561931846b02ddfe69c21afead0fe.tar.bz2
upstream-760952ad022561931846b02ddfe69c21afead0fe.zip
ath79: restore sysupgrade support for ja76pf2 and routerstations
Because the bug described in FS#2428 has been fixed with bf2870c1d9e1 ("kernel: fix mtd partition erase < parent_erasesize writes") these devices can now safely do sysupgrade. Restore sysupgrade support disabled in: 0cc87b3bacee ("ath79: image: disable sysupgrade images for routerstations and ja76pf2") cc5256a8bfa0 ("ath79: base-files: disable sysupgrade for routerstations and ja76pf2") Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com> [move Build block, remove check-size argument, wrap sysupgrade line, make commit message easier to read] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 4b4a67fd4d..9bec159cf0 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -5,6 +5,14 @@ KERNEL_LOADADDR = 0x80060000
DEVICE_VARS += LOADER_FLASH_OFFS LOADER_TYPE
+define Build/combined-image
+ sh $(TOPDIR)/scripts/combined-image.sh \
+ "$(IMAGE_KERNEL)" \
+ "$@" \
+ "$@.new"
+ @mv $@.new $@
+endef
+
define Build/loader-common
rm -rf $@.src
$(MAKE) -C lzma-loader \