aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/image/Makefile
diff options
context:
space:
mode:
authorPaul Fertser <fercerpav@gmail.com>2021-02-14 12:16:33 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 19:21:38 +0100
commit25d6af98d0a59e8e1db0f168f33ad239826af5c9 (patch)
tree40bf6dbf1214db8ca88fed8126485c7ed34b50ec /target/linux/ath79/image/Makefile
parentce4cb8e51d8d4b24267653250c3f7310d208bfaa (diff)
downloadupstream-25d6af98d0a59e8e1db0f168f33ad239826af5c9.tar.gz
upstream-25d6af98d0a59e8e1db0f168f33ad239826af5c9.tar.bz2
upstream-25d6af98d0a59e8e1db0f168f33ad239826af5c9.zip
ath79: fix factory image generation for Netgear and Zyxel boards
The factory images need to embed specific IDs to pass verification with the OEM firmware (including TFTP recovery), so they need to be per-device variables. Fixes: ab1584a797ad ("ath79: netgear: trim down uImage customisations") Fixes: 459c8c9ef816 ("ath79: add support for ZyXEL NBG6616") Reported-by: Marcin Juszkiewicz <marcin-openwrt@juszkiewicz.com.pl> Signed-off-by: Paul Fertser <fercerpav@gmail.com> [minor commit message adjustments, sort DEVICE_VARS] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath79/image/Makefile')
-rw-r--r--target/linux/ath79/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 4a51cf1fbf..c2d2474336 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -4,6 +4,8 @@ include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR = 0x80060000
DEVICE_VARS += LOADER_FLASH_OFFS LOADER_TYPE
+DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
+DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
define Build/combined-image
sh $(TOPDIR)/scripts/combined-image.sh \