aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-07-17 17:09:13 +0800
committerJohn Crispin <john@phrozen.org>2018-07-30 10:43:33 +0200
commit83d2dbc59924c90dd865de113a55d60826ac0c04 (patch)
tree2fb028041fcffa2e1de5342fa6f9a98462da5e48 /target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
parent24cbe27bb7ff83b9bb3a2640904bced1a2d14a8d (diff)
downloadupstream-83d2dbc59924c90dd865de113a55d60826ac0c04.tar.gz
upstream-83d2dbc59924c90dd865de113a55d60826ac0c04.tar.bz2
upstream-83d2dbc59924c90dd865de113a55d60826ac0c04.zip
ath79: ag71xx: Split mdio driver into an independent platform device.
We need to have mdio1 belonging to gmac1 initialized before gmac0. Split it into a separated mdio device to get both mdios ready before probing gmac. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile')
-rw-r--r--target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile b/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
index ed74e3b5e6..3636077166 100644
--- a/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
+++ b/target/linux/ath79/files/drivers/net/ethernet/atheros/ag71xx/Makefile
@@ -6,10 +6,10 @@ ag71xx-y += ag71xx_main.o
ag71xx-y += ag71xx_gmac.o
ag71xx-y += ag71xx_ethtool.o
ag71xx-y += ag71xx_phy.o
-ag71xx-y += ag71xx_mdio.o
ag71xx-y += ag71xx_ar7240.o
ag71xx-$(CONFIG_AG71XX_DEBUG_FS) += ag71xx_debugfs.o
+obj-$(CONFIG_AG71XX) += ag71xx_mdio.o
obj-$(CONFIG_AG71XX) += ag71xx.o