aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2018-08-02 15:14:10 +0800
committerMathias Kresin <dev@kresin.me>2018-08-06 07:31:54 +0200
commit8288af1e18adfe68bc556df93521881d1e5d0eda (patch)
treebe3cb352858cba82fc68b0a70cf8d3c1d78963b6 /target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi
parent2da431e5839019bf83da2c83559430ac237bd537 (diff)
downloadupstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.gz
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.tar.bz2
upstream-8288af1e18adfe68bc556df93521881d1e5d0eda.zip
ath79: rename dts/image using manufacturer_board scheme
This helps getting rid of SUPPORTED_DEVICES which can be auto-generated in image/Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi')
-rw-r--r--target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi157
1 files changed, 157 insertions, 0 deletions
diff --git a/target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi b/target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi
new file mode 100644
index 0000000000..9d8c1a022e
--- /dev/null
+++ b/target/linux/ath79/dts/ar9331_tplink_tl-wr741nd-v4.dtsi
@@ -0,0 +1,157 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+ compatible = "tplink,tl-wr741n-v4", "qca,ar9331";
+ model = "TP-Link TL-WR741N/ND v4";
+
+ aliases {
+ serial0 = &uart;
+ led-status = &led_system;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
+ };
+
+ wps {
+ label = "wps";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 26 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ pinctrl-names = "default";
+ pinctrl-0 = <&switch_led_pins>;
+
+ lan1 {
+ label = "tp-link:green:lan1";
+ gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+ };
+
+ lan2 {
+ label = "tp-link:green:lan2";
+ gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+ };
+
+ lan3 {
+ label = "tp-link:green:lan3";
+ gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+ };
+
+ lan4 {
+ label = "tp-link:green:lan4";
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ };
+
+ qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+ };
+
+ led_system: system {
+ label = "tp-link:green:system";
+ gpios = <&gpio 27 GPIO_ACTIVE_HIGH>;
+ };
+
+ wan {
+ label = "tp-link:green:wan";
+ gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
+ };
+
+ wlan {
+ label = "tp-link:green:wlan";
+ gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+ default-state = "off";
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+};
+
+&spi {
+ status = "okay";
+ num-cs = <1>;
+
+ flash@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ reg = <0x0 0x20000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ firmware: partition@20000 {
+ reg = <0x20000 0x3d0000>;
+ label = "firmware";
+ };
+
+ art: partition@3f0000 {
+ reg = <0x3f0000 0x10000>;
+ label = "art";
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <1>;
+
+ gmac-config {
+ device = <&gmac>;
+
+ switch-phy-addr-swap = <1>;
+ switch-phy-swap = <1>;
+ };
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <(-1)>;
+};
+
+&gpio {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};