aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath79/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-05-06 10:20:11 +0200
committerJohn Crispin <john@phrozen.org>2018-05-07 08:06:51 +0200
commit53c474abbdfef8eb3499e2d10c9ad491788b8a72 (patch)
treeacd19415420664f59bc63c1ceb4ad37bb7323027 /target/linux/ath79/Makefile
parent3dc523f232ff01d31d59345f5fa6de508d5059ef (diff)
downloadupstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.gz
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.tar.bz2
upstream-53c474abbdfef8eb3499e2d10c9ad491788b8a72.zip
ath79: add new OF only target for QCA MIPS silicon
This target aims to replace ar71xx mid-term. The big part that is still missing is making the MMIO/AHB wifi work using OF. NAND and mikrotik subtargets will follow. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ath79/Makefile')
-rw-r--r--target/linux/ath79/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ath79/Makefile b/target/linux/ath79/Makefile
new file mode 100644
index 0000000000..e331cb4210
--- /dev/null
+++ b/target/linux/ath79/Makefile
@@ -0,0 +1,19 @@
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ath79
+BOARDNAME:=Atheros ATH79 (DTS)
+CPU_TYPE:=24kc
+SUBTARGETS:=generic
+
+FEATURES:=ramdisk source-only
+
+KERNEL_PATCHVER:=4.14
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-gpio-button-hotplug swconfig \
+ kmod-ath9k wpad-mini uboot-envtools
+
+$(eval $(call BuildTarget))