aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ath25
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-07-28 20:47:35 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-30 21:49:22 +0200
commite9f7923a1d4b327ef4b9ac25fbe197f2b4ea61d7 (patch)
tree8c8061e2123b755ec9592eee3a8ddeef60a99017 /target/linux/ath25
parent1d5260cf72763d92ba8c4aff61b3605e37af614a (diff)
downloadupstream-e9f7923a1d4b327ef4b9ac25fbe197f2b4ea61d7.tar.gz
upstream-e9f7923a1d4b327ef4b9ac25fbe197f2b4ea61d7.tar.bz2
upstream-e9f7923a1d4b327ef4b9ac25fbe197f2b4ea61d7.zip
treewide: mark devices as BROKEN instead of commenting out
This adds the newly introduced BROKEN flag to a bunch of devices that previously just had TARGET_DEVICES commented out. By this, we can select them in make menuconfig when BROKEN developer config option is selected, instead of having to edit the code. In contrast to DEFAULT := n, this is meant to cover devices that don't boot or don't compile at all. ath25: np25g, wpe53g both disabled during kernel bump 3.18->4.4 without reason given f89a20a89aeb ("ath25: update kernel from 3.18 to 4.4") bcm53xx: linksys-ea6300-v1, linksys-ea9200, linksys-ea9500 broken due to insufficient/broken TRX support 55ff15cfd509 ("bcm53xx: disable building Linksys EA6300 V1 image") cd0f9900a4cd ("bcm53xx: parepare for building more Linksys images") bcm63xx: tplink-archer-c5-v2, tplink-archer-c9-v1 disabled when kernel 5.4 support was added, probably broken 50c6938b95a0 ("bcm53xx: add v5.4 support") Signed-off-by: Petr Štetiar <ynezz@true.cz> [limit to subset of devices, use BROKEN, adjust commit message/title] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ath25')
-rw-r--r--target/linux/ath25/image/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ath25/image/Makefile b/target/linux/ath25/image/Makefile
index e1ebb159cd..8066ba61a8 100644
--- a/target/linux/ath25/image/Makefile
+++ b/target/linux/ath25/image/Makefile
@@ -99,15 +99,17 @@ define Device/np25g
DEVICE_MODEL := NP25G
KERNEL := kernel-bin | gzip-kernel
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw np25g
+ BROKEN := y
endef
-#TARGET_DEVICES += np25g
+TARGET_DEVICES += np25g
define Device/wpe53g
DEVICE_VENDOR := Compex
DEVICE_MODEL := WPE53G
KERNEL := kernel-bin | gzip-kernel
IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkmylofw wpe53g
+ BROKEN := y
endef
-#TARGET_DEVICES += wpe53g
+TARGET_DEVICES += wpe53g
$(eval $(call BuildImage))