aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-01-11 18:05:11 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-01-27 00:16:13 +0100
commitfd5c16870169bb76dd3d3bcfbcc6a112f74aeefe (patch)
tree43db8ee2a39320df1ebc4a3e03bf22719ec45e6d /target/linux/at91
parent538127cf981e0f7f71a75b365d95575b0f7263e1 (diff)
downloadupstream-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.tar.gz
upstream-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.tar.bz2
upstream-fd5c16870169bb76dd3d3bcfbcc6a112f74aeefe.zip
kernel: Build: Split kmod-regmap
This reduces the needed modifications to the mainline Linux kernel and also makes the regmap package work with an out of tree kernel which does not have these modifications. The regmap-core is only added when it is really build as a module. The regmap-core is normally bool so it cannot be built as a module in an unmodified kernel. When it is selected by on other kernel module it will always be selected as build in and it also does not show up in $(LINUX_DIR)/modules.builtin as it is not supposed to be a kernel module. When it is not in $(LINUX_DIR)/modules.builtin the build system expects it to be built as a .ko file. Just check if the module is really there and only add it in that case. This splits the regmap package into multiple packages, one for each bus type. This way only the bus maps which are really needed have to be added. This also splits the I2C, SPI and MMIO regmap into separate packages to not require all these subsystems to build them, on an unmodified upstream kernel this also causes problems in some situations. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/at91/modules.mk b/target/linux/at91/modules.mk
index 30858ce654..998c042ee1 100644
--- a/target/linux/at91/modules.mk
+++ b/target/linux/at91/modules.mk
@@ -53,7 +53,7 @@ $(eval $(call KernelPackage,at91-adc))
define KernelPackage/at91-udc
SUBMENU:=$(USB_MENU)
TITLE:=USB Device Controller on atmel SoC
- DEPENDS:=@TARGET_at91 +kmod-usb-gadget +kmod-regmap
+ DEPENDS:=@TARGET_at91 +kmod-usb-gadget +kmod-regmap-core
KCONFIG:=CONFIG_USB_AT91
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko),)
FILES:=$(LINUX_DIR)/drivers/usb/gadget/udc/at91_udc.ko