aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorMoritz Warning <moritzwarning@web.de>2019-09-10 00:00:40 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-19 13:16:57 +0200
commite6114ff925a1371bd98fe476ca4a99e5c08e5088 (patch)
tree5ce0fc3f5e4a7a05ba0499630ccf6c8e7cfa07a8 /target/linux/at91
parent1997feb2ffa670643a8392fdafc5dacd2b347929 (diff)
downloadupstream-e6114ff925a1371bd98fe476ca4a99e5c08e5088.tar.gz
upstream-e6114ff925a1371bd98fe476ca4a99e5c08e5088.tar.bz2
upstream-e6114ff925a1371bd98fe476ca4a99e5c08e5088.zip
at91: split up remaining DEVICE_TITLE definitions
DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT Signed-off-by: Moritz Warning <moritzwarning@web.de>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/sama5.mk18
1 files changed, 12 insertions, 6 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 1e4366cefa..031e62587e 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -56,7 +56,8 @@ endef
define Device/at91-sama5d2_xplained
$(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D2 Xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
@@ -64,7 +65,8 @@ TARGET_DEVICES += at91-sama5d2_xplained
define Device/at91-sama5d27_som1_ek
$(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D27 SOM1 Ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
@@ -72,7 +74,8 @@ TARGET_DEVICES += at91-sama5d27_som1_ek
define Device/at91-sama5d2_ptc_ek
$(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D2 PTC Ek
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
@@ -81,7 +84,8 @@ TARGET_DEVICES += at91-sama5d2_ptc_ek
define Device/at91-sama5d3_xplained
$(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D3 Xplained
KERNEL_SIZE := 6144k
$(Device/evaluation-sdimage)
endef
@@ -91,7 +95,8 @@ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
define Device/wb50n
$(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
+ DEVICE_VENDOR := Laird
+ DEVICE_MODEL := WB50N
DEVICE_PACKAGES := \
kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
@@ -108,7 +113,8 @@ endif
define Device/at91-sama5d4_xplained
$(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ DEVICE_VENDOR := Microchip
+ DEVICE_MODEL := SAMA5D4 Xplained
KERNEL_SIZE := 6144k
BLOCKSIZE := 256k
PAGESIZE := 4096