aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-28 10:21:14 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-30 12:12:37 +0200
commitaff084adf339cf9fd966ce8e2b1173b3ff51fd48 (patch)
tree092b8013cd7f8ed13755f898ad129680c3c715b4 /target/linux/at91
parent28e00650a5756cab9405198392e30ae545f2ae4c (diff)
downloadupstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.tar.gz
upstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.tar.bz2
upstream-aff084adf339cf9fd966ce8e2b1173b3ff51fd48.zip
at91: Merge SAMA5 subtargets
Instead of maintaining 3 very similar subtargets merge them into one. This does not use the Arm NEON extension any more, because the SAMA5D3 does not support NEON. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Sandeep Sheriker <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/Makefile2
-rw-r--r--target/linux/at91/config-4.95
-rw-r--r--target/linux/at91/image/Makefile10
-rw-r--r--target/linux/at91/image/sama5.mk71
-rw-r--r--target/linux/at91/image/sama5d2.mk31
-rw-r--r--target/linux/at91/image/sama5d3.mk33
-rw-r--r--target/linux/at91/image/sama5d4.mk19
-rw-r--r--target/linux/at91/sama5/config-default0
-rw-r--r--target/linux/at91/sama5/target.mk10
-rw-r--r--target/linux/at91/sama5d2/config-default3
-rw-r--r--target/linux/at91/sama5d2/target.mk10
-rw-r--r--target/linux/at91/sama5d3/config-default2
-rw-r--r--target/linux/at91/sama5d3/target.mk10
-rw-r--r--target/linux/at91/sama5d4/target.mk10
14 files changed, 87 insertions, 129 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
index d71e0850ff..cae3c6278b 100644
--- a/target/linux/at91/Makefile
+++ b/target/linux/at91/Makefile
@@ -11,7 +11,7 @@ BOARD:=at91
MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
BOARDNAME:=Microchip (Atmel AT91)
FEATURES:=ext4 squashfs targz usb usbgadget ubifs
-SUBTARGETS:=sama5d2 sama5d3 sama5d4 legacy
+SUBTARGETS:=sama5 legacy
KERNEL_PATCHVER:=4.9
diff --git a/target/linux/at91/config-4.9 b/target/linux/at91/config-4.9
index 452cfd5aa3..ad18d6b826 100644
--- a/target/linux/at91/config-4.9
+++ b/target/linux/at91/config-4.9
@@ -214,6 +214,7 @@ CONFIG_HAVE_ARCH_PFN_VALID=y
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
CONFIG_HAVE_ARCH_TRACEHOOK=y
CONFIG_HAVE_ARM_SMCCC=y
+CONFIG_HAVE_AT91_GENERATED_CLK=y
CONFIG_HAVE_AT91_H32MX=y
CONFIG_HAVE_AT91_SMD=y
CONFIG_HAVE_AT91_USB_CLK=y
@@ -464,8 +465,8 @@ CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_TIMER=y
CONFIG_SOC_BUS=y
CONFIG_SOC_SAMA5=y
-# CONFIG_SOC_SAMA5D2 is not set
-# CONFIG_SOC_SAMA5D3 is not set
+CONFIG_SOC_SAMA5D2=y
+CONFIG_SOC_SAMA5D3=y
CONFIG_SOC_SAMA5D4=y
CONFIG_SOC_SAM_V7=y
CONFIG_SOUND=y
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 49d93aa97d..f4d942b682 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -16,14 +16,8 @@ endef
ifeq ($(SUBTARGET),legacy)
include ./legacy.mk
endif
-ifeq ($(SUBTARGET),sama5d2)
-include ./sama5d2.mk
-endif
-ifeq ($(SUBTARGET),sama5d3)
-include ./sama5d3.mk
-endif
-ifeq ($(SUBTARGET),sama5d4)
-include ./sama5d4.mk
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
endif
AT91_SD_BOOT_PARTSIZE:=64
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
new file mode 100644
index 0000000000..f9a190c8b2
--- /dev/null
+++ b/target/linux/at91/image/sama5.mk
@@ -0,0 +1,71 @@
+
+define Device/default-nand
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
+endef
+
+define Device/at91-sama5d2_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_xplained
+
+define Device/at91-sama5d27_som1_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d27_som1_ek
+
+define Device/at91-sama5d2_ptc_ek
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d2_ptc_ek
+
+
+define Device/at91-sama5d3_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
+ KERNEL_SIZE := 6144k
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d3_xplained
+
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ define Device/wb50n
+ $(Device/evaluation-fit)
+ DEVICE_TITLE := Laird WB50N
+ DEVICE_PACKAGES := \
+ kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
+ kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
+ kmod-leds-gpio
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
+ endef
+ TARGET_DEVICES += wb50n
+ endif
+endif
+
+
+define Device/at91-sama5d4_xplained
+ $(Device/evaluation-dtb)
+ DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
+ KERNEL_SIZE := 6144k
+ BLOCKSIZE := 256k
+ PAGESIZE := 4096
+ SUBPAGESIZE := 2048
+ MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
+ $(Device/evaluation-sdimage)
+endef
+TARGET_DEVICES += at91-sama5d4_xplained
diff --git a/target/linux/at91/image/sama5d2.mk b/target/linux/at91/image/sama5d2.mk
deleted file mode 100644
index b841448633..0000000000
--- a/target/linux/at91/image/sama5d2.mk
+++ /dev/null
@@ -1,31 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d2_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_xplained
-
-define Device/at91-sama5d27_som1_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D27 SOM1 Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d27_som1_ek
-
-define Device/at91-sama5d2_ptc_ek
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D2 PTC Ek
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d2_ptc_ek
diff --git a/target/linux/at91/image/sama5d3.mk b/target/linux/at91/image/sama5d3.mk
index f48c981030..e69de29bb2 100644
--- a/target/linux/at91/image/sama5d3.mk
+++ b/target/linux/at91/image/sama5d3.mk
@@ -1,33 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d3_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D3 Xplained
- KERNEL_SIZE := 6144k
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d3_xplained
-
-ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
- ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
- define Device/wb50n
- $(Device/evaluation-fit)
- DEVICE_TITLE := Laird WB50N
- DEVICE_PACKAGES := \
- kmod-mmc-at91 kmod-ath6kl-sdio ath6k-firmware \
- kmod-usb-storage kmod-fs-vfat kmod-fs-msdos \
- kmod-leds-gpio
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 955
- endef
- TARGET_DEVICES += wb50n
- endif
-endif
diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
index 1140c3c4b2..e69de29bb2 100644
--- a/target/linux/at91/image/sama5d4.mk
+++ b/target/linux/at91/image/sama5d4.mk
@@ -1,19 +0,0 @@
-
-define Device/default-nand
- BLOCKSIZE := 128k
- PAGESIZE := 2048
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB -c 2048
-endef
-
-define Device/at91-sama5d4_xplained
- $(Device/evaluation-dtb)
- DEVICE_TITLE := Microchip(Atmel AT91) SAMA5D4 Xplained
- KERNEL_SIZE := 6144k
- BLOCKSIZE := 256k
- PAGESIZE := 4096
- SUBPAGESIZE := 2048
- MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
- $(Device/evaluation-sdimage)
-endef
-TARGET_DEVICES += at91-sama5d4_xplained
diff --git a/target/linux/at91/sama5/config-default b/target/linux/at91/sama5/config-default
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/target/linux/at91/sama5/config-default
diff --git a/target/linux/at91/sama5/target.mk b/target/linux/at91/sama5/target.mk
new file mode 100644
index 0000000000..35df05b70d
--- /dev/null
+++ b/target/linux/at91/sama5/target.mk
@@ -0,0 +1,10 @@
+BOARDNAME:=SAMA5 boards(Cortex-A5)
+CPU_TYPE:=cortex-a5
+CPU_SUBTYPE:=vfpv4
+FEATURES+=fpu
+DEFAULT_PACKAGES += kmod-usb2
+
+define Target/Description
+ Build generic firmware for Microchip(Atmel AT91) SAMA5D2,
+ SAMA5D3 and SAMA5D4 MPU's using the ARMv7 instruction set.
+endef
diff --git a/target/linux/at91/sama5d2/config-default b/target/linux/at91/sama5d2/config-default
deleted file mode 100644
index 1724375c33..0000000000
--- a/target/linux/at91/sama5d2/config-default
+++ /dev/null
@@ -1,3 +0,0 @@
-CONFIG_HAVE_AT91_GENERATED_CLK=y
-CONFIG_SOC_SAMA5D2=y
-# CONFIG_SOC_SAMA5D4 is not set
diff --git a/target/linux/at91/sama5d2/target.mk b/target/linux/at91/sama5d2/target.mk
deleted file mode 100644
index 63f50aeea1..0000000000
--- a/target/linux/at91/sama5d2/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-BOARDNAME:=SAMA5D2 boards(Cortex-A5)
-CPU_TYPE:=cortex-a5
-CPU_SUBTYPE:=neon-vfpv4
-FEATURES+=fpu
-DEFAULT_PACKAGES += kmod-usb2
-
-define Target/Description
- Build generic firmware for Microchip(Atmel AT91) SAMA5D2 MPU's
- using the ARMv7 instruction set.
-endef
diff --git a/target/linux/at91/sama5d3/config-default b/target/linux/at91/sama5d3/config-default
deleted file mode 100644
index eb0ec01cb9..0000000000
--- a/target/linux/at91/sama5d3/config-default
+++ /dev/null
@@ -1,2 +0,0 @@
-CONFIG_SOC_SAMA5D3=y
-# CONFIG_SOC_SAMA5D4 is not set
diff --git a/target/linux/at91/sama5d3/target.mk b/target/linux/at91/sama5d3/target.mk
deleted file mode 100644
index d30931bfc0..0000000000
--- a/target/linux/at91/sama5d3/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-BOARDNAME:=SAMA5D3 boards(Cortex-A5)
-CPU_TYPE:=cortex-a5
-CPU_SUBTYPE:=vfpv4
-FEATURES+=fpu
-DEFAULT_PACKAGES += kmod-usb2
-
-define Target/Description
- Build generic firmware for Microchip(Atmel AT91) SAMA5D3 MPU's
- using the ARMv7 instruction set.
-endef
diff --git a/target/linux/at91/sama5d4/target.mk b/target/linux/at91/sama5d4/target.mk
deleted file mode 100644
index 2bbab60d81..0000000000
--- a/target/linux/at91/sama5d4/target.mk
+++ /dev/null
@@ -1,10 +0,0 @@
-BOARDNAME:=SAMA5D4 boards(Cortex-A5)
-CPU_TYPE:=cortex-a5
-CPU_SUBTYPE:=neon-vfpv4
-FEATURES+=fpu
-DEFAULT_PACKAGES += kmod-usb2
-
-define Target/Description
- Build generic firmware for Microchip(Atmel AT91) SAMA5D4 MPU's
- using the ARMv7 instruction set.
-endef