aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-09-11 18:35:55 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-09-21 01:09:22 +0200
commit612e9ed7b8d2123a64e5617b2f0ea3f99102e31c (patch)
tree7027a8383e845fcf45f0a7a5dcae4f6fe2370ecb /target/linux/at91
parentab19627ecc3923687fd339f4f23dc45572d00ce0 (diff)
downloadupstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.tar.gz
upstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.tar.bz2
upstream-612e9ed7b8d2123a64e5617b2f0ea3f99102e31c.zip
at91:sama5: create fit image
create fit image & add it to sdcard image for sama5 target device. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/Makefile2
-rw-r--r--target/linux/at91/image/sama5.mk4
2 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/at91/image/Makefile b/target/linux/at91/image/Makefile
index 3b01d42131..adb7c6d0ba 100644
--- a/target/linux/at91/image/Makefile
+++ b/target/linux/at91/image/Makefile
@@ -63,6 +63,8 @@ define Device/evaluation-dtb
$(Device/evaluation-zImage)
IMAGES += dtb
IMAGE/dtb := install-dtb
+ KERNEL_SUFFIX := -fit-zImage.itb
+ KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
endef
define Device/evaluation-fit
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index a737ba508b..1e4366cefa 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -11,7 +11,9 @@ define Build/at91-sdcard
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
- mcopy -i $@.boot $(KDIR)/zImage ::zImage
+ mcopy -i $@.boot \
+ $(KDIR)/$(DEVICE_NAME)-fit-zImage.itb \
+ ::$(DEVICE_NAME:at91-%=%)-fit.itb
$(if $(findstring at91-sama5d27_som1_ek,$@), \
mcopy -i $@.boot \