aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2019-08-14 21:02:17 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 23:09:04 +0200
commit552c48ea4375420cf3db1f91038a3f4eca47361b (patch)
tree559e67c4870b33975980228d2ce390bb8c0ddbe0 /target/linux/at91
parent05a81abb5ff58501d589b2c949b607e515b52f92 (diff)
downloadupstream-552c48ea4375420cf3db1f91038a3f4eca47361b.tar.gz
upstream-552c48ea4375420cf3db1f91038a3f4eca47361b.tar.bz2
upstream-552c48ea4375420cf3db1f91038a3f4eca47361b.zip
at91/image/sama5.mk: check for sama5d4_xplained device
check for sama5d4_xplained device while copying at91bootstrap binary to sdcard image. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'target/linux/at91')
-rw-r--r--target/linux/at91/image/sama5.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index 4fee464a00..a737ba508b 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -23,9 +23,13 @@ define Build/at91-sdcard
mcopy -i $@.boot \
$(BIN_DIR)/u-boot-$(DEVICE_NAME:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- mcopy -i $@.boot \
- $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
- ::BOOT.bin)
+ $(if $(findstring sama5d4_xplained, $@), \
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
+ ::BOOT.bin,
+ mcopy -i $@.boot \
+ $(BIN_DIR)/at91bootstrap-$(DEVICE_NAME:at91-%=%)sd_uboot/at91bootstrap.bin \
+ ::BOOT.bin))
$(CP) uboot-env.txt $@-uboot-env.txt
sed -i '2d;3d' $@-uboot-env.txt